Browse Source

Update docs building, cleanup

Update docs building and do a few cleanups
* Switch to sphinx-build
* Update requirements for Sphinx and openstackdocstheme for
  python 3, create doc/requirements.txt
* Remove unneeded doc and translation sections from setup.cfg
* Remove install_command, it's unneeded, the default is fine.
* Use TOX_CONSTRAINTS instead of obsolete UPPER_CONSTRAINTS
* Update hacking to 3.0

Change-Id: Ief34ac947ec23d6a9d4aad3640a4a61d0173578b
changes/90/725090/1
Andreas Jaeger 10 months ago
parent
commit
a2262b757c
4 changed files with 18 additions and 24 deletions
  1. +8
    -0
      doc/requirements.txt
  2. +0
    -14
      setup.cfg
  3. +1
    -5
      test-requirements.txt
  4. +9
    -5
      tox.ini

+ 8
- 0
doc/requirements.txt View File

@ -0,0 +1,8 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
sphinx>=2.0.0,!=2.1.0 # BSD
openstackdocstheme>=2.0.0 # Apache-2.0
# releasenotes
reno>=2.5.0 # Apache-2.0

+ 0
- 14
setup.cfg View File

@ -24,20 +24,6 @@ classifier =
packages =
solum_tempest_plugin
[compile_catalog]
directory = solum_tempest_plugin/locale
domain = solum_tempest_plugin
[update_catalog]
domain = solum_tempest_plugin
output_dir = solum_tempest_plugin/locale
input_file = solum_tempest_plugin/locale/solum_tempest_plugin.pot
[extract_messages]
keywords = _ gettext ngettext l_ lazy_gettext
mapping_file = babel.cfg
output_file = solum_tempest_plugin/locale/solum_tempest_plugin.pot
[entry_points]
tempest.test_plugins =
solum_tests = solum_tempest_plugin.plugin:SolumTempestPlugin

+ 1
- 5
test-requirements.txt View File

@ -2,14 +2,10 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking<0.13,>=0.12.0 # Apache-2.0
hacking>=3.0,<3.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
python-subunit>=1.0.0 # Apache-2.0/BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
oslotest>=3.2.0 # Apache-2.0
stestr>=2.0.0 # Apache-2.0
testtools>=2.2.0 # MIT
openstackdocstheme>=1.18.1 # Apache-2.0
# releasenotes
reno>=2.5.0 # Apache-2.0

+ 9
- 5
tox.ini View File

@ -1,18 +1,18 @@
[tox]
minversion = 2.0
envlist = py37,py36,pypy,pep8
envlist = py37,py36,pep8
skipsdist = True
ignore_basepython_conflict = True
[testenv]
basepython = python3
usedevelop = True
install_command = pip install {opts} {packages}
setenv =
VIRTUAL_ENV={envdir}
PYTHONWARNINGS=default::DeprecationWarning
deps = -r{toxinidir}/test-requirements.txt
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
deps =
-c{env:TOX_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r{toxinidir}/test-requirements.txt
commands = stestr run --slowest {posargs}
[testenv:pep8]
@ -33,9 +33,13 @@ commands =
coverage report
[testenv:docs]
commands = python setup.py build_sphinx
deps =
-c{env:TOX_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r{toxinidir}/doc/requirements.txt
commands = sphinx-build -W -b html doc/source doc/build/html
[testenv:releasenotes]
deps = {[testenv:docs]deps}
commands =
sphinx-build -a -E -W -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html


Loading…
Cancel
Save