Browse Source

Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg
- Update classifiers
- Update requirements, no need for python_version anymore
- Use sphinx-build for doc building everywhere

Change-Id: I1ebce1290995c89cb91a1227ee9473bf820606f3
changes/23/717623/1
Andreas Jaeger 1 year ago
parent
commit
054ad31084
  1. 12
      setup.cfg
  2. 9
      setup.py
  3. 2
      test-requirements.txt
  4. 2
      tox.ini

12
setup.cfg

@ -6,6 +6,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/sushy/latest/
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@ -13,6 +14,8 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@ -26,15 +29,6 @@ console_scripts =
sushy-emulator = sushy_tools.emulator.main:main
sushy-static = sushy_tools.static.main:main
[build_sphinx]
all-files = 1
warning-is-error = 1
source-dir = doc/source
build-dir = doc/build
[upload_sphinx]
upload-dir = doc/build/html
[compile_catalog]
directory = sushy_tools/locale
domain = sushy_tools

9
setup.py

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

2
test-requirements.txt

@ -8,7 +8,7 @@ coverage!=4.4,>=4.0 # Apache-2.0
# used by libvirt driver
libvirt-python!=4.1.0,>=3.7.0 # LGPLv2+
python-subunit>=1.0.0 # Apache-2.0/BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
openstackdocstheme>=1.20.0 # Apache-2.0
# used by nova driver
openstacksdk>=0.11.2 # Apache-2.0

2
tox.ini

@ -35,7 +35,7 @@ commands =
coverage xml -o cover/coverage.xml
[testenv:docs]
commands = python setup.py build_sphinx
commands = sphinx-build -W -b html doc/source doc/build/html
[testenv:pdf-docs]
whitelist_externals = make

Loading…
Cancel
Save