Browse Source

Remove <py3.5 dependencies from requirements.txt

The requirements repo is support python 3.5 as oldest python version
while swift still supports py27.

thus, requirements-check will fail on a couple of lines in swift.  The
check is only run when these files are touched.

The py2.7 packagers we know about aren't depending on upstream
requirements.txt for correctness and aside from all the production
deployments running on py2.7 we only realistically support >=py3.7

There's no good reason for our requirements.txt to be "unspported" by
the openstack requirements check job.  Since they only support >=py3.5
we can change our requirements.txt inline with that.  This should be
fine for everything we could hope to get out of both our
requirements.txt and the check!

Co-Authored-By: Clay Gerrard <clay.gerrard@gmail.com>
Change-Id: Ibf8000498528c401707be8b0b91b8355cd993786
changes/89/732989/4
Andreas Jaeger 1 year ago
parent
commit
019bade19c
2 changed files with 10 additions and 4 deletions
  1. +1
    -2
      doc/requirements.txt
  2. +9
    -2
      requirements.txt

+ 1
- 2
doc/requirements.txt View File

@ -2,8 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
# this is required for the docs build jobs
sphinx>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx>=1.6.2;python_version>='3.4' # BSD
sphinx>=1.6.2 # BSD
openstackdocstheme>=1.30.0 # Apache-2.0
reno>=1.8.0 # Apache-2.0
os-api-ref>=1.0.0 # Apache-2.0


+ 9
- 2
requirements.txt View File

@ -2,7 +2,6 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
dnspython>=1.15.0;python_version=='2.7' # http://www.dnspython.org/LICENSE
eventlet>=0.25.0 # MIT
greenlet>=0.3.2
netifaces>=0.8,!=0.10.0,!=0.10.1
@ -13,4 +12,12 @@ six>=1.10.0
xattr>=0.4;sys_platform!='win32' # MIT
PyECLib>=1.3.1 # BSD
cryptography>=2.0.2 # BSD/Apache-2.0
ipaddress>=1.0.16;python_version<'3.3' # PSF
# For python 2.7, the following requirements are needed; they are not
# included since the requirments-check check will fail otherwise since
# global requirements do not support these anymore.
# Fortunately, these packages come in as dependencies from others and
# thus the py27 jobs still work.
#
# dnspython>=1.15.0;python_version=='2.7' # http://www.dnspython.org/LICENSE
# ipaddress>=1.0.16;python_version<'3.3' # PSF

Loading…
Cancel
Save