Browse Source

Clean up requirements a bit

* Drop osc from test-requirements (and lower-constraints)

  I'm not clear on where/how we use it; I think it was a hold-over from
  swift3?

* Pin python-keystoneclient in our py2-constraints

  Something sees to have changed with the pip resolver that means it
  keeps trying to install a newer, py3-only version for our py2 jobs.

Change-Id: Ie37ac077517e1ece5fa6bf163d1ab5e316ced509
changes/56/764856/2
Tim Burke 7 months ago
parent
commit
0d37492c65
3 changed files with 1 additions and 2 deletions
  1. +0
    -1
      lower-constraints.txt
  2. +1
    -0
      py2-constraints.txt
  3. +0
    -1
      test-requirements.txt

+ 0
- 1
lower-constraints.txt View File

@ -62,7 +62,6 @@ python-keystoneclient==2.0.0
python-mimeparse==1.6.0
python-subunit==1.2.0
python-swiftclient==3.2.0
python-openstackclient==3.12.0
pytz==2018.3
PyYAML==3.12
requests==2.14.2


+ 1
- 0
py2-constraints.txt View File

@ -70,3 +70,4 @@ greenlet===0.4.15
oslo.utils===3.42.1
gitdb===0.6.4
gitdb2===2.0.6
python-keystoneclient===3.22.0

+ 0
- 1
test-requirements.txt View File

@ -12,7 +12,6 @@ os-testr>=0.8.0 # Apache-2.0
mock>=2.0 # BSD
python-swiftclient>=3.2.0
python-keystoneclient!=2.1.0,>=2.0.0 # Apache-2.0
python-openstackclient>=3.12.0
boto>=2.32.1
boto3>=1.9
botocore>=1.12


Loading…
Cancel
Save