Browse Source

Update some constraints for py2

We've recently started seeing some failures in the gate related to these
projects, and they have final py2-supporting versions.

Change-Id: If81fc352c8b2b1f03f3fa7b79c56dfcf981ced70
changes/69/784869/3
Tim Burke 4 months ago
parent
commit
1895213d25
  1. 1
      lower-constraints.txt
  2. 3
      py2-constraints.txt
  3. 4
      tools/playbooks/common/install_dependencies.yaml

1
lower-constraints.txt

@ -78,3 +78,4 @@ urllib3==1.22
voluptuous==0.11.1
wrapt==1.10.11
xattr==0.4
pycadf===2.10.0

3
py2-constraints.txt

@ -73,3 +73,6 @@ gitdb2===2.0.6
# Projects that are known to have had a final py2-supporting release
bandit===1.6.2
python-keystoneclient===3.22.0
dnspython===1.16.0
setuptools===44.1.1
pycadf===2.10.0

4
tools/playbooks/common/install_dependencies.yaml

@ -40,4 +40,6 @@
- nose
- pyeclib
- python-swiftclient
- mock
# For some reason, pip on py2 isn't smart enough to prevent us
# trying to install a too-new mock??
- 'mock<4'
Loading…
Cancel
Save