Browse Source

Dep's should be restricted by upper-constraints

Tox trying to install latest versions for building docs which may
not be supported by stable and lower branches, so should be
restricted by respective version's upper-constraints.txt

Change-Id: I599d4ea430cc1e65bb50d0481617b005febf6de2
(cherry picked from commit ee641dffc9)
changes/19/793019/2
wu.shiming 7 months ago
committed by Tim Burke
parent
commit
29eefcd0de
1 changed files with 6 additions and 2 deletions
  1. +6
    -2
      tox.ini

+ 6
- 2
tox.ini View File

@ -104,7 +104,9 @@ commands = {posargs}
[testenv:docs]
basepython = python3
deps = -r{toxinidir}/doc/requirements.txt
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/ussuri}
-r{toxinidir}/doc/requirements.txt
commands = sphinx-build -W -b html doc/source doc/build/html
[testenv:api-ref]
@ -155,7 +157,9 @@ commands = bindep test
[testenv:releasenotes]
basepython = python3
deps = -r{toxinidir}/doc/requirements.txt
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/ussuri}
-r{toxinidir}/doc/requirements.txt
commands = sphinx-build -a -W -E -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html
[testenv:lower-constraints]


Loading…
Cancel
Save