Browse Source

Use latest pip in gate jobs

We've seen failures with probe tests lately where dnspython 2.0.0 is
getting installed even though it doesn't support py2 anymore. I think
using latest pip should be better about noticing that and installing the
last 1.x release intead?

Change-Id: I6eda54ccd2792effadb334ce9324887132b62b6f
(cherry picked from commit 1c91547643)
changes/05/742305/1
Tim Burke 3 weeks ago
committed by Tim Burke
parent
commit
498454a139
1 changed files with 5 additions and 0 deletions
  1. +5
    -0
      tools/playbooks/common/install_dependencies.yaml

+ 5
- 0
tools/playbooks/common/install_dependencies.yaml View File

@@ -17,6 +17,11 @@
roles:
- ensure-pip
tasks:
- name: upgrade pip
pip:
name: pip
extra_args: --upgrade

- name: installing dependencies
yum: name={{ item }} state=present
with_items:


Loading…
Cancel
Save