Browse Source

Dep's should be restricted by upper-constraints

Tox trying to install latest versions for building docs which may
not be supported by stable and lower branches, so should be
restricted by respective version's upper-constraints.txt

Change-Id: I599d4ea430cc1e65bb50d0481617b005febf6de2
(cherry picked from commit ee641dffc9)
changes/18/793018/3
wu.shiming 7 months ago
committed by Tim Burke
parent
commit
c0bb5b2f3f
1 changed files with 6 additions and 2 deletions
  1. +6
    -2
      tox.ini

+ 6
- 2
tox.ini View File

@ -90,7 +90,9 @@ commands = {posargs}
[testenv:docs]
basepython = python3
deps = -r{toxinidir}/doc/requirements.txt
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/victoria}
-r{toxinidir}/doc/requirements.txt
commands = sphinx-build -W -b html doc/source doc/build/html
[testenv:api-ref]
@ -141,7 +143,9 @@ commands = bindep test
[testenv:releasenotes]
basepython = python3
deps = -r{toxinidir}/doc/requirements.txt
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/victoria}
-r{toxinidir}/doc/requirements.txt
commands = sphinx-build -a -W -E -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html
[testenv:lower-constraints]


Loading…
Cancel
Save