Browse Source

Drop block storage v2 API

This change is to update python-cinderclient to 8.0.0 because cinder
dropped v2 API and doesn't support its client for the API. It also
updates depending packages as below.

* python-cinderclient 8.0.0 depends on pbr>=5.5.0
* python-cinderclient 8.0.0 depends on oslo.utils>=4.8.0
* python-cinderclient 8.0.0 depends on stevedore>=3.3.0
* python-cinderclient 8.0.0 depends on requests>=2.25.1
* python-cinderclient 8.0.0 depends on keystoneauth1>=4.3.1

Signed-off-by: Yasufumi Ogawa <yasufum.o@gmail.com>
Change-Id: Id01fe417acf4da4e5360dfba3bc2cc96df2b6889
changes/29/802429/6
Yasufumi Ogawa 1 year ago
parent
commit
385c4b441e
  1. 14
      lower-constraints.txt
  2. 8
      requirements.txt
  3. 2
      test-requirements.txt
  4. 6
      upper-constraints.txt

14
lower-constraints.txt

@ -43,7 +43,7 @@ jmespath==0.9.3
jsonpatch==1.21
jsonpointer==2.0
jsonschema==3.2.0
keystoneauth1==3.18.0
keystoneauth1==4.3.1
keystonemiddleware==4.17.0
kombu==4.3.0
kubernetes==11.0.0
@ -67,7 +67,7 @@ oslo.concurrency==3.26.0
oslo.config==6.8.0
oslo.context==2.22.0
oslo.db==5.0.0
oslo.i18n==3.20.0
oslo.i18n==5.0.1
oslo.log==3.36.0
oslo.messaging==9.3.0
oslo.middleware==3.31.0
@ -77,14 +77,14 @@ oslo.rootwrap==5.8.0
oslo.serialization==2.18.0
oslo.service==1.24.0
oslo.upgradecheck==1.3.0
oslo.utils==4.5.0
oslo.utils==4.8.0
oslo.versionedobjects==1.33.3
oslotest==3.2.0
packaging==20.4
paramiko==2.7.1
Paste==2.0.2
PasteDeploy==1.5.0
pbr==2.0.0
pbr==5.5.0
pkg-resources==0.0.0
prettytable==0.7.2
psutil==5.4.3
@ -114,12 +114,12 @@ python-novaclient==9.1.0
python-subunit==1.0.0
python-swiftclient==3.5.0
python-tackerclient==0.8.0
python-cinderclient==3.3.0
python-cinderclient==8.0.0
pytz==2018.3
PyYAML==5.1
repoze.lru==0.7
requests-oauthlib==0.8.0
requests==2.20.0
requests==2.25.1
requests-mock==1.2.0
requestsexceptions==1.4.0
restructuredtext-lint==1.1.3
@ -134,7 +134,7 @@ SQLAlchemy==1.3.11
sqlparse==0.2.4
statsd==3.2.2
stestr==2.0.0
stevedore==1.20.0
stevedore==3.3.0
tempest==22.0.0
Tempita==0.5.2
tenacity==4.12.0

8
requirements.txt

@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr!=2.1.0,>=2.0.0 # Apache-2.0
pbr>=5.5.0 # Apache-2.0
Paste>=2.0.2 # MIT
PasteDeploy>=1.5.0 # MIT
@ -9,7 +9,7 @@ Routes>=2.3.1 # MIT
amqp>=2.4.0
anyjson>=0.3.3 # BSD
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
requests>=2.20.0 # Apache-2.0
requests>=2.25.1 # Apache-2.0
jsonschema>=3.2.0 # MIT
keystonemiddleware>=4.17.0 # Apache-2.0
kombu>=4.3.0 # BSD
@ -19,7 +19,7 @@ WebOb>=1.7.1 # MIT
python-heatclient>=1.10.0 # Apache-2.0
python-keystoneclient>=3.8.0 # Apache-2.0
alembic>=0.9.6 # MIT
stevedore>=1.20.0 # Apache-2.0
stevedore>=3.3.0 # Apache-2.0
oslo.concurrency>=3.26.0 # Apache-2.0
oslo.config>=6.8.0 # Apache-2.0
oslo.context>=2.22.0 # Apache-2.0
@ -33,7 +33,7 @@ oslo.rootwrap>=5.8.0 # Apache-2.0
oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
oslo.service!=1.28.1,>=1.24.0 # Apache-2.0
oslo.upgradecheck>=1.3.0 # Apache-2.0
oslo.utils>=4.5.0 # Apache-2.0
oslo.utils>=4.8.0 # Apache-2.0
oslo.versionedobjects>=1.33.3 # Apache-2.0
openstacksdk>=0.44.0 # Apache-2.0
python-neutronclient>=6.7.0 # Apache-2.0

2
test-requirements.txt

@ -11,7 +11,7 @@ fixtures>=3.0.0 # Apache-2.0/BSD
hacking>=4.0.0,<4.1.0 # Apache-2.0
python-subunit>=1.0.0 # Apache-2.0/BSD
python-tackerclient>=0.8.0 # Apache-2.0
python-cinderclient>=3.3.0 # Apache-2.0
python-cinderclient>=8.0.0 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
stestr>=2.0.0 # Apache-2.0
tempest>=22.0.0 # Apache-2.0

6
upper-constraints.txt

@ -42,7 +42,7 @@ sphinxcontrib-nwdiag===2.0.0
rbd-iscsi-client===0.1.8
requests-aws===0.1.8
alabaster===0.7.12
pbr===5.5.1
pbr===5.6.0
munch===2.5.0
waiting===1.4.1
attrs===20.3.0
@ -340,7 +340,7 @@ testtools===2.4.0
infi.dtypes.iqn===0.4.0
XStatic-tv4===1.2.7.0
XStatic-JSEncrypt===2.3.1.1
python-cinderclient===7.3.0
python-cinderclient===8.0.0
keystonemiddleware===9.2.0
django-formtools===2.2
python-ceilometerclient===2.9.0
@ -552,7 +552,7 @@ filelock===3.0.12
python-tackerclient===1.5.0
python-heatclient===2.3.0
kafka-python===2.0.2
oslo.utils===4.8.0
oslo.utils===4.9.2
python-editor===1.0.4
gitdb2===4.0.2
requests-kerberos===0.12.0

Loading…
Cancel
Save