update sphinx requirement

syncs sphinx dependency with global requirements.
It caps python 2 since sphinx 2.0 no longer supports Python 2.7.

Change-Id: Ia4ad99c8201f48292c35e7b50604d1d87c467eb3
(cherry picked from commit c3a23500ce)
dharmendra 4 years ago committed by dharmendra kushwaha
parent baff0a7370
commit bd23a64501

@ -1,7 +1,8 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinxcontrib-apidoc>=0.2.0 # BSD
openstackdocstheme>=1.18.1 # Apache-2.0
os-api-ref>=1.4.0 # Apache-2.0