Browse Source

[ussuri][goal] Drop python 2.7 support and testing

OpenStack is dropping the py2.7 support in ussuri cycle.

tempest-stress is ready with python 3 and ok to drop the
python 2.7 support.

Complete discussion & schedule can be found in
- http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html
- https://etherpad.openstack.org/p/drop-python2-support

Ussuri Communtiy-wide goal:
https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html

Change-Id: Iea3eb7606ed89ef4ec61ca5d392d44bdfc927c3b
changes/33/705533/1
Ghanshyam Mann 2 years ago
parent
commit
858fc6bf84
  1. 3
      .zuul.yaml
  2. 5
      releasenotes/notes/drop-py-2-7-6296cbf589c0881c.yaml
  3. 3
      setup.cfg
  4. 12
      tox.ini

3
.zuul.yaml

@ -1,4 +1,3 @@
- project:
templates:
- openstack-python-jobs
- openstack-python3-train-jobs
- openstack-python3-ussuri-jobs

5
releasenotes/notes/drop-py-2-7-6296cbf589c0881c.yaml

@ -0,0 +1,5 @@
---
upgrade:
- |
Python 2.7 support has been dropped. The minimum version of Python now
supported by tempest-stress is Python 3.6.

3
setup.cfg

@ -6,6 +6,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://opendev.org/openstack/tempest-stress/src/branch/master/README.rst
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@ -13,8 +14,6 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7

12
tox.ini

@ -1,9 +1,11 @@
[tox]
minversion = 2.0
envlist = py36,py37,py27,pypy,pep8
minversion = 3.1.1
envlist = py36,py37,pypy,pep8
skipsdist = True
ignore_basepython_conflict = True
[testenv]
basepython = python3
usedevelop = True
setenv =
VIRTUAL_ENV={envdir}
@ -15,23 +17,19 @@ deps = -r{toxinidir}/test-requirements.txt
commands = stestr --test-path ./tempest_stress/tests run {posargs}
[testenv:stress]
basepython = python3
envdir = .tox/tempest_stress
sitepackages = False
commands =
run-tempest-stress {posargs}
[testenv:pep8]
basepython = python3
sitepackages = False
commands = flake8 {posargs}
[testenv:venv]
basepython = python3
commands = {posargs}
[testenv:cover]
basepython = python3
setenv =
VIRTUAL_ENV={envdir}
PYTHON=coverage run --source tempest_stress --parallel-mode
@ -42,11 +40,9 @@ commands =
coverage xml -o cover/coverage.xml
[testenv:docs]
basepython = python3
commands = python setup.py build_sphinx
[testenv:debug]
basepython = python3
commands = oslo_debug_helper {posargs}
[flake8]

Loading…
Cancel
Save