Update to hieroglyph 2.0

hieroglyph 2.0 works with python 3 and Sphinx 2, update to it.
Update some other requirements as well.

Cleanup tox.ini a bit.

Switch to openstackdocstheme 2.2.1 version. Using
this versions will allow especially:
* Linking from HTML to PDF document
* Allow parallel building of documents
* Fix some rendering problems

Update Sphinx version as well.

Disable openstackdocs_auto_version to not auto-version the documents.

Disable openstackdocs_auto_name to use 'project' variable as name.

Change pygments_style to 'native' since old theme version always used
'native' and the theme now respects the setting and using 'sphinx' can
lead to some strange rendering.

openstackdocstheme renames some variables, so follow the renames
before the next release removes them. A couple of variables are also
not needed anymore, remove them.

See also
http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014971.html

Change-Id: Ib8ba3e3f514688d06a07598e7d6ceffa79f26220
changes/18/738318/2
Andreas Jaeger 3 years ago
parent bc7b372cb2
commit e43daab321

@ -35,16 +35,14 @@ master_doc = 'index'
# General information about the project.
project = u'OpenStack Training Guides'
bug_tag = u'training-guides'
openstackdocs_bug_tag = u'training-guides'
copyright = u'2014-2019, OpenStack contributors'
repository_name = 'openstack/training-guides'
bug_project = 'training-guides'
openstackdocs_repo_name = 'openstack/training-guides'
openstackdocs_bug_project = 'training-guides'
openstackdocs_auto_name = False
openstackdocs_auto_version = False
pygments_style = 'native'
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
# built documents.
#
# The short X.Y version.
# The repo is not versioned.
version = ''
# The full version, including alpha/beta/rc tags.

@ -34,10 +34,13 @@ master_doc = 'index'
# General information about the project.
project = u'Upstream Training Guide'
bug_tag = u'upstream'
openstackdocs_bug_tag = u'upstream'
copyright = u'2014-2019, OpenStack contributors'
repository_name = 'openstack/training-guides'
bug_project = 'training-guides'
openstackdocs_repo_name = 'openstack/training-guides'
openstackdocs_bug_project = 'training-guides'
openstackdocs_auto_name = False
openstackdocs_auto_version = False
pygments_style = 'native'
# No need to show a version number
version = ''

@ -1,9 +1,8 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr>=1.6
# hieroglyph 1.0.0 does not work with Sphinx 3.0
sphinx>=1.6.2,<3.0.0 # BSD
openstackdocstheme>=1.20.0
hieroglyph>=1.0.0
pbr>=1.8
sphinx>=2.0.0,!=2.1.0 # BSD
openstackdocstheme>=2.2.1 # Apache-2.0
hieroglyph>=2.0.0
doc8

@ -9,12 +9,9 @@ basepython = python3
setenv = VIRTUAL_ENV={envdir}
deps = -r{toxinidir}/test-requirements.txt
whitelist_externals =
echo
mkdir
rm
rsync
msgcat
awk
bash
[testenv:venv]

Loading…
Cancel
Save