Browse Source

Dropping the py35 testing

All the integration testing has been moved to
Bionic now[1] and py3.5 is not tested runtime for
Train or stable/stein[2].

As per below ML thread, we are good to drop the py35
testing now:
http://lists.openstack.org/pipermail/openstack-discuss/2019-April/005097.html

[1] http://lists.openstack.org/pipermail/openstack-discuss/2019-April/004647.html
[2]
https://governance.openstack.org/tc/reference/runtimes/stein.html
https://governance.openstack.org/tc/reference/runtimes/train.html

Change-Id: I50ee998ebcf20dff9aa6238b254021d6d2378448
changes/41/653041/1
Ghanshyam Mann 3 years ago
parent
commit
8cc38152e1
  1. 10
      .zuul.yaml
  2. 2
      setup.cfg
  3. 2
      tox.ini

10
.zuul.yaml

@ -39,7 +39,7 @@
- project:
templates:
- openstack-python-jobs-neutron
- openstack-python35-jobs-neutron
- openstack-python36-jobs-neutron
- openstack-python36-jobs
- check-requirements
- publish-openstack-docs-pti
@ -56,10 +56,6 @@
required-projects:
- openstack/neutron
- openstack/networking-sfc
- openstack-tox-py35:
required-projects:
- openstack/neutron
- openstack/networking-sfc
- openstack-tox-py36:
required-projects:
- openstack/neutron
@ -77,10 +73,6 @@
required-projects:
- openstack/neutron
- openstack/networking-sfc
- openstack-tox-py35:
required-projects:
- openstack/neutron
- openstack/networking-sfc
- openstack-tox-py36:
required-projects:
- openstack/neutron

2
setup.cfg

@ -15,7 +15,7 @@ classifier =
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
[files]
packages =

2
tox.ini

@ -1,6 +1,6 @@
[tox]
minversion = 1.6
envlist = py35,py27,pypy,pep8
envlist = py36,py27,pypy,pep8
skipsdist = True
[testenv]

Loading…
Cancel
Save