Browse Source

Fix ci issues

1) Drop tripleo-common constraint

The new pip dependency resolver doesn't work well with links. See pip
issue #8253.  Also we should require a release of tripleo-common for CI
to function. This is similar to what we do with tripleoclient. This
change also bumps the lower bound for tripleo-common to the latest for
master which is 13.0.0. This should be adjusted for backports.

2) Exclude reqs and tox files from modules job temporarly, will be
fixed in next patch

Change-Id: I1363d911a39e4072a706c61d83d113db6f85f71c
Closes-Bug: #1908079
changes/83/766983/14
Alex Schultz 4 months ago
parent
commit
82659a89a7
7 changed files with 9 additions and 15 deletions
  1. +1
    -1
      ansible-requirements.txt
  2. +0
    -1
      constraints.txt
  3. +1
    -1
      molecule-requirements.txt
  4. +1
    -1
      requirements.txt
  5. +3
    -8
      tox.ini
  6. +3
    -1
      zuul.d/layout.yaml
  7. +0
    -2
      zuul.d/molecule.yaml

+ 1
- 1
ansible-requirements.txt View File

@ -1,4 +1,4 @@
ansible>=2.8,!=2.8.9,!=2.9.12,<2.10.0
metalsmith>=1.2.0 # Apache-2.0
importlib-metadata<2.0.0
importlib-metadata
jsonschema # MIT

+ 0
- 1
constraints.txt View File

@ -1 +0,0 @@
-e git+https://github.com/openstack/tripleo-common@master#egg=tripleo-common

+ 1
- 1
molecule-requirements.txt View File

@ -1,7 +1,7 @@
# this is required for the molecule jobs
ansi2html
# https://github.com/sqlalchemy/dogpile.cache/issues/178 (openstacksdk)
dogpile.cache>=0.6.5,<0.9.1 # MIT
dogpile.cache>=0.6.5,!=0.9.1 # MIT
openstacksdk
pytest
pytest-cov


+ 1
- 1
requirements.txt View File

@ -1,5 +1,5 @@
pbr>=1.6
tripleo-common>=11.3.1 # Apache-2.0
tripleo-common # Apache-2.0
python-glanceclient>=2.8.0 # Apache-2.0
python-heatclient # Apache-2.0
python-ironicclient!=2.5.2,!=2.7.1,!=3.0.0,>=2.3.0,<4.0.0;python_version=='2.7' # Apache-2.0


+ 3
- 8
tox.ini View File

@ -5,7 +5,7 @@ skipdist = True
[testenv]
usedevelop = True
install_command = python3 -m pip install -c{env:TOX_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master} -c{toxinidir}/constraints.txt {opts} {packages}
install_command = python3 -m pip install -c{env:TOX_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master} {opts} {packages}
passenv = *
setenv =
ANSIBLE_ACTION_PLUGINS={toxinidir}/tripleo_ansible/roles.galaxy/config_template/action:{toxinidir}/tripleo_ansible/ansible_plugins/action
@ -49,8 +49,8 @@ sitepackages = False
setenv =
TOX_CONSTRAINTS_FILE=file:///dev/null
deps =
pre-commit>=2.7.1
virtualenv>=20.0.31
pre-commit
virtualenv
-r {toxinidir}/ansible-requirements.txt
commands =
pip check
@ -72,11 +72,6 @@ deps =
-c{env:TOX_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/master}
-r {toxinidir}/doc/requirements.txt
commands=
# NOTE(cloudnull): This will ensure we always have the latest version of
# tripleo-common installed, which is required for documentation
# to build when running with in development modules which use
# tripleo-common as a library.
pip install tripleo-common -c{toxinidir}/constraints.txt --force --upgrade
doc8 doc
sphinx-build -a -E -W -d doc/build/doctrees --keep-going -b html doc/source doc/build/html -T


+ 3
- 1
zuul.d/layout.yaml View File

@ -6,7 +6,9 @@
- openstack-python3-wallaby-jobs
check:
jobs:
- tripleo-ci-centos-8-content-provider
- tripleo-ci-centos-8-content-provider:
irrelevant-files:
- ^tox.ini$
- openstack-tox-linters: &tripleo-linters
nodeset: centos-8
- openstack-tox-docs: &tripleo-docs


+ 0
- 2
zuul.d/molecule.yaml View File

@ -203,8 +203,6 @@
- job:
files:
- ^tripleo_ansible/ansible_plugins/.*$
- ^tox.ini
- ^molecule-requirements.txt
name: tripleo-ansible-centos-8-molecule-tripleo-modules
parent: tripleo-ansible-centos-8-base
- job:


Loading…
Cancel
Save