Browse Source

Changed minversion in tox to 3.18.0

The patch bumps min version of tox to 3.18.0 in order to
replace tox's whitelist_externals by allowlist_externals option:
https://github.com/tox-dev/tox/blob/master/docs/changelog.rst#v3180-2020-07-23

Change-Id: Ia66c28fb935a127102982f8b644397fd35b09a96
changes/79/794479/1
likui 2 months ago
parent
commit
9532e28e57
  1. 6
      tox.ini

6
tox.ini

@ -1,5 +1,5 @@
[tox]
minversion = 3.8
minversion = 3.18.0
envlist = linters,py
skipsdist = True
@ -36,7 +36,7 @@ deps =
-r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands = stestr run {posargs}
whitelist_externals =
allowlist_externals =
bash
tox
@ -97,6 +97,6 @@ commands = bash -c tools/releasenotes_tox.sh
[testenv:requirements]
deps =
-egit+https://opendev.org/openstack/requirements#egg=openstack-requirements
whitelist_externals = sh
allowlist_externals = sh
commands =
sh -c '{envdir}/src/openstack-requirements/playbooks/files/project-requirements-change.py --req {envdir}/src/openstack-requirements --local {toxinidir} master'
Loading…
Cancel
Save