Browse Source

fix linters

Partial-Fix: https://bugs.launchpad.net/tripleo/+bug/1848512
Change-Id: I460f5593b66c073a75b713bac848dcd66b639e9c
changes/70/689170/1
Sorin Sbarnea 2 years ago
parent
commit
d384320b13
2 changed files with 10 additions and 1 deletions
  1. +3
    -0
      bindep.txt
  2. +7
    -1
      tox.ini

+ 3
- 0
bindep.txt View File

@ -31,3 +31,6 @@ gzip
# Required to build language docs
gettext
# debian requirements (linters)
libffi-dev [platform:dpkg]
libssl-dev [platform:dpkg]

+ 7
- 1
tox.ini View File

@ -19,9 +19,12 @@ setenv =
PIP_DISABLE_PIP_VERSION_CHECK=1
passenv =
ANSIBLE_*
CURL_CA_BUNDLE
DOCKER_*
PYTEST*
REQUESTS_CA_BUNDLE
SSH_AUTH_SOCK
SSL_CERT_FILE
TERM
install_command = pip install {opts} {packages}
deps =
@ -77,7 +80,10 @@ commands =
[testenv:linters]
skip_install = true
deps = pre-commit
deps =
# workaround for https://github.com/ansible/ansible-lint/issues/590
virtualenv==16.3.0 # 16.7.6 not working
pre-commit
commands =
python -m pre_commit run -a {posargs:}
bash -c tools/check_duplicate_jinja_blocks.sh


Loading…
Cancel
Save