A Python library for code common to TripleO CLI and TripleO UI.
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 

35 lines
1.3 KiB

# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr!=2.1.0,>=2.0.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD
GitPython>=1.0.1;python_version>='3.0' # BSD License (3 clause)
GitPython>=1.0.1,<2.1.12;python_version<'3.0' # BSD License (3 clause)
eventlet!=0.20.1,>=0.20.0 # MIT
python-heatclient>=1.10.0 # Apache-2.0
oslo.config>=5.2.0 # Apache-2.0
oslo.log>=3.36.0 # Apache-2.0
oslo.rootwrap>=5.8.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
python-glanceclient>=2.8.0 # Apache-2.0
python-ironicclient>=2.3.0 # Apache-2.0
six>=1.10.0 # MIT
mistral-lib>=0.3.0 # Apache-2.0
oslo.concurrency>=3.26.0 # Apache-2.0
python-ironic-inspector-client>=1.5.0 # Apache-2.0
python-mistralclient!=3.2.0,>=3.1.0 # Apache-2.0
Jinja2>=2.10 # BSD License (3 clause)
python-novaclient>=9.1.0 # Apache-2.0
passlib>=1.7.0 # BSD
netifaces>=0.10.4 # MIT
paramiko>=2.0.0 # LGPLv2.1+
netaddr>=0.7.18 # BSD
python-zaqarclient>=1.0.0 # Apache-2.0
python-keystoneclient>=3.8.0 # Apache-2.0
keystoneauth1>=3.4.0 # Apache-2.0
tenacity>=4.4.0 # Apache-2.0
futures>=3.0.0;python_version=='2.7' or python_version=='2.6' # BSD
metalsmith>=0.13.0 # Apache-2.0
jsonschema>=2.6.0 # MIT
requests>=2.18.0,!=2.20.0 # Apache-2.0