Browse Source

Ensure old installation match new images and get python-docker.

If user is coming from a <=Newton version, then it may be missing that
package. Make sure it's installed before during update or upgrade.

Change-Id: If0ae6c65468ef19183419261781745fafb56c9b7
Closes-Bug: #1917913
changes/87/778987/1
Sofer Athlan-Guyot 1 month ago
parent
commit
0f47a4de9b
1 changed files with 14 additions and 0 deletions
  1. +14
    -0
      puppet/services/tripleo-packages.yaml

+ 14
- 0
puppet/services/tripleo-packages.yaml View File

@ -300,6 +300,13 @@ outputs:
name: '*'
state: latest
exclude: ceph*,librados*,librbd*,libcephfs*,librgw*,python-rados*,python-rbd*,python-cephfs*,python-rgw*,rbd-mirror
- name: Make sure python-docker is installed.
when:
- step|int == 3
- not skip_package_update|bool
yum:
name: 'python-docker'
state: 'installed'
update_tasks:
# With the layered product packaging, the key package is rhosp-openvswitch. It depends on
# a openvswitch package that includes the version as part of the name (e.g openvswitch2.10).
@ -423,6 +430,13 @@ outputs:
name: '*'
state: latest
update_cache: yes
- name: Make sure python-docker is installed.
when:
- step|int == 3
- not skip_package_update|bool
yum:
name: 'python-docker'
state: 'installed'
# This is failsafe unless openvswitch package does something to the systemd service state.
- name: Ensure openvswitch is running after update
when:


Loading…
Cancel
Save