Browse Source

Update/upgrade prepare/converge in config-download era

We inherit the `prepare` commands from deploy, in Rocky we will
automatically get config-download env file there so no need to
explicitly disable DeploymentSteps in *-prepare.yaml files too. We
should also disable the WorkflowSteps in config-download environment,
as they too aren't meant to be used with config-download.

Similarly, for `converge` commands in the *-converge.yaml files we
shouldn't re-enable the DeploymentSteps and WorkflowSteps, as that
would go against using config-download.

Change-Id: I89f54ba9a0a15afd26da4d4b26aba8ef09ebf04b
changes/20/583320/3
Jiri Stransky 4 years ago
parent
commit
39321cca71
  1. 1
      environments/config-download-environment.yaml
  2. 6
      environments/lifecycle/ffwd-upgrade-converge.yaml
  3. 8
      environments/lifecycle/ffwd-upgrade-prepare.yaml
  4. 3
      environments/lifecycle/update-converge.yaml
  5. 2
      environments/lifecycle/update-prepare.yaml
  6. 3
      environments/lifecycle/upgrade-converge.yaml
  7. 4
      environments/lifecycle/upgrade-prepare.yaml

1
environments/config-download-environment.yaml

@ -8,6 +8,7 @@ resource_registry:
OS::Heat::StructuredDeployment: ../config-download-structured.yaml
OS::TripleO::DeploymentSteps: OS::Heat::None
OS::TripleO::WorkflowSteps: OS::Heat::None
OS::TripleO::Ssh::KnownHostsDeployment: OS::Heat::None
OS::TripleO::Ssh::HostPubKey: OS::Heat::None

6
environments/lifecycle/ffwd-upgrade-converge.yaml

@ -1,12 +1,6 @@
# Environment file used in the last step of a ffwd overcloud upgrade.
# This file is required by the tripleoclient and not expected to be updated
# by the operator. Please use additional -e env.yaml.
resource_registry:
OS::TripleO::SoftwareDeployment: OS::Heat::StructuredDeployment
OS::TripleO::DeploymentSteps: OS::Heat::StructuredDeploymentGroup
OS::TripleO::WorkflowSteps: OS::Mistral::ExternalResource
OS::Heat::SoftwareDeployment: OS::TripleO::Heat::SoftwareDeployment
OS::Heat::StructuredDeployment: OS::TripleO::Heat::StructuredDeployment
parameter_defaults:
CephAnsiblePlaybook: ['/usr/share/ceph-ansible/site-docker.yml.sample']
UpgradeLevelNovaCompute: ''

8
environments/lifecycle/ffwd-upgrade-prepare.yaml

@ -5,14 +5,6 @@ resource_registry:
OS::TripleO::Services::Core: OS::Heat::None
OS::TripleO::Services::GlanceRegistry: OS::Heat::None
OS::TripleO::Services::VipHosts: OS::Heat::None
# Set the config-download environment for the stack update:
OS::TripleO::SoftwareDeployment: ../../config-download-structured.yaml
OS::Heat::SoftwareDeployment: ../../config-download-software.yaml
OS::Heat::StructuredDeployment: ../../config-download-structured.yaml
OS::TripleO::DeploymentSteps: OS::Heat::None
OS::TripleO::WorkflowSteps: OS::Heat::None
OS::TripleO::Ssh::KnownHostsDeployment: OS::Heat::None
OS::TripleO::Ssh::HostPubKey: OS::Heat::None
# Deprecated/Name changed services
OS::TripleO::Services::FluentdClient: OS::Heat::None

3
environments/lifecycle/update-converge.yaml

@ -1,9 +1,6 @@
# Environment file used in the last step of an overcloud update.
# This file is required by the tripleoclient and not expected to be updated
# by the operator. Please use additional -e env.yaml for customizations.
resource_registry:
OS::TripleO::DeploymentSteps: OS::Heat::StructuredDeploymentGroup
OS::TripleO::WorkflowSteps: OS::Mistral::ExternalResource
parameter_defaults:
CephAnsiblePlaybook: ['/usr/share/ceph-ansible/site-docker.yml.sample']
UpgradeLevelNovaCompute: ''

2
environments/lifecycle/update-prepare.yaml

@ -2,7 +2,5 @@
# This file is required by the tripleoclient and not expected to be updated
# by the operator. Please use additional -e env.yaml for customizations.
resource_registry:
OS::TripleO::DeploymentSteps: OS::Heat::None
OS::TripleO::WorkflowSteps: OS::Heat::None
OS::TripleO::Tasks::*PreConfig: OS::Heat::None
OS::TripleO::Tasks::*PostConfig: OS::Heat::None

3
environments/lifecycle/upgrade-converge.yaml

@ -1,9 +1,6 @@
# Environment file used in the last step of an overcloud upgrade.
# This file is required by the tripleoclient and not expected to be updated
# by the operator. Please use additional -e env.yaml.
resource_registry:
OS::TripleO::DeploymentSteps: OS::Heat::StructuredDeploymentGroup
OS::TripleO::WorkflowSteps: OS::Mistral::ExternalResource
parameter_defaults:
CephAnsiblePlaybook: ['/usr/share/ceph-ansible/site-docker.yml.sample']
UpgradeLevelNovaCompute: ''

4
environments/lifecycle/upgrade-prepare.yaml

@ -2,12 +2,8 @@
# This file is required by the tripleoclient and not expected to be updated
# by the operator. Please use additional -e env.yaml.
resource_registry:
OS::TripleO::DeploymentSteps: OS::Heat::None
OS::TripleO::WorkflowSteps: OS::Heat::None
OS::TripleO::Tasks::*PreConfig: OS::Heat::None
OS::TripleO::Tasks::*PostConfig: OS::Heat::None
# Deprecated/Name changed services
OS::TripleO::Services::FluentdClient: OS::Heat::None
parameter_defaults:
UpgradeLevelNovaCompute: auto

Loading…
Cancel
Save