Browse Source

Merge "Use docker_container Ansible module" into stable/rocky

tags/9.4.1
Zuul 1 month ago
parent
commit
500827dd1a

+ 2
- 2
docker/services/octavia-api.yaml View File

@@ -218,7 +218,7 @@ outputs:
218 218
           when:
219 219
             - step|int == 2
220 220
             - internal_tls_enabled|bool
221
-          docker:
221
+          docker_container:
222 222
             name: octavia_api_tls_proxy
223 223
             state: absent
224 224
       upgrade_tasks:
@@ -263,7 +263,7 @@ outputs:
263 263
               service: name=httpd state=stopped
264 264
             - name: remove TLS proxy if configured and running
265 265
               when: internal_tls_enabled|bool
266
-              docker:
266
+              docker_container:
267 267
                 name: octavia_api_tls_proxy
268 268
                 state: absent
269 269
       metadata_settings:

+ 5
- 0
releasenotes/notes/fix-octavia-update-upgrade-tasks-docker-067489654b2b7e18.yaml View File

@@ -0,0 +1,5 @@
1
+---
2
+fixes:
3
+  - |
4
+    Fixed an issue where the update and upgrade tasks for Octavia would use the
5
+    removed docker module in Ansible 2.4.

Loading…
Cancel
Save