Browse Source

Merge "Swap tasks to avoid non-existing variable error." into stable/train

changes/81/706381/1
Zuul 2 weeks ago
parent
commit
673e82d772
11 changed files with 22 additions and 37 deletions
  1. +2
    -2
      deployment/cinder/cinder-backup-pacemaker-puppet.yaml
  2. +2
    -2
      deployment/cinder/cinder-volume-pacemaker-puppet.yaml
  3. +2
    -4
      deployment/database/mysql-pacemaker-puppet.yaml
  4. +2
    -4
      deployment/database/redis-pacemaker-puppet.yaml
  5. +2
    -4
      deployment/haproxy/haproxy-pacemaker-puppet.yaml
  6. +2
    -2
      deployment/manila/manila-share-pacemaker-puppet.yaml
  7. +2
    -4
      deployment/ovn/ovn-dbs-pacemaker-puppet.yaml
  8. +2
    -3
      deployment/pacemaker/pacemaker-baremetal-puppet.yaml
  9. +2
    -4
      deployment/rabbitmq/rabbitmq-messaging-notify-pacemaker-puppet.yaml
  10. +2
    -4
      deployment/rabbitmq/rabbitmq-messaging-pacemaker-puppet.yaml
  11. +2
    -4
      deployment/rabbitmq/rabbitmq-messaging-rpc-pacemaker-puppet.yaml

+ 2
- 2
deployment/cinder/cinder-backup-pacemaker-puppet.yaml View File

@@ -344,8 +344,6 @@ outputs:
- groups['cinder_backup'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ cinder_backup_node_names }}"
- debug:
msg: "Prepare cinder_backup upgrade for {{ cinder_backup_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade cinder_backup without
@@ -356,6 +354,8 @@ outputs:
cinder_backup_short_node_names_upgraded | length == 0 or
cinder_backup_node_names_upgraded is not defined or
cinder_backup_node_names_upgraded | length == 0
- debug:
msg: "Prepare cinder_backup upgrade for {{ cinder_backup_short_node_names_upgraded }}"
- name: remove cinder_backup init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 2
deployment/cinder/cinder-volume-pacemaker-puppet.yaml View File

@@ -330,8 +330,6 @@ outputs:
- groups['cinder_volume'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ cinder_volume_node_names }}"
- debug:
msg: "Prepare cinder_volume upgrade for {{ cinder_volume_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade cinder_volume without
@@ -342,6 +340,8 @@ outputs:
cinder_volume_short_node_names_upgraded | length == 0 or
cinder_volume_node_names_upgraded is not defined or
cinder_volume_node_names_upgraded | length == 0
- debug:
msg: "Prepare cinder_volume upgrade for {{ cinder_volume_short_node_names_upgraded }}"
- name: remove cinder_volume init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 4
deployment/database/mysql-pacemaker-puppet.yaml View File

@@ -490,9 +490,6 @@ outputs:
- groups['mysql'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ mysql_node_names }}"

- debug:
msg: "Prepare galera upgrade for {{ mysql_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade galera without staged upgrade.
@@ -502,7 +499,8 @@ outputs:
mysql_short_node_names_upgraded | length == 0 or
mysql_node_names_upgraded is not defined or
mysql_node_names_upgraded | length == 0

- debug:
msg: "Prepare galera upgrade for {{ mysql_short_node_names_upgraded }}"
- name: remove mysql init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 4
deployment/database/redis-pacemaker-puppet.yaml View File

@@ -423,9 +423,6 @@ outputs:
- groups['redis'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ redis_short_node_names }}"

- debug:
msg: "Prepare redis upgrade for {{ redis_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade redis without staged
@@ -434,7 +431,8 @@ outputs:
when: >-
redis_short_node_names_upgraded is not defined or
redis_short_node_names_upgraded | length == 0

- debug:
msg: "Prepare redis upgrade for {{ redis_short_node_names_upgraded }}"
- name: remove redis init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 4
deployment/haproxy/haproxy-pacemaker-puppet.yaml View File

@@ -542,9 +542,6 @@ outputs:
- groups['haproxy'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ haproxy_short_node_names }}"

- debug:
msg: "Prepare haproxy upgrade for {{ haproxy_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade haproxy without staged
@@ -553,7 +550,8 @@ outputs:
when: >-
haproxy_short_node_names_upgraded is not defined or
haproxy_short_node_names_upgraded | length == 0

- debug:
msg: "Prepare haproxy upgrade for {{ haproxy_short_node_names_upgraded }}"
- name: remove haproxy init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 2
deployment/manila/manila-share-pacemaker-puppet.yaml View File

@@ -332,8 +332,6 @@ outputs:
- groups['manila_share'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ manila_share_node_names }}"
- debug:
msg: "Prepare manila_share upgrade for {{ manila_share_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade manila_share without
@@ -344,6 +342,8 @@ outputs:
manila_share_short_node_names_upgraded | length == 0 or
manila_share_node_names_upgraded is not defined or
manila_share_node_names_upgraded | length == 0
- debug:
msg: "Prepare manila_share upgrade for {{ manila_share_short_node_names_upgraded }}"
- name: remove manila_share init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 4
deployment/ovn/ovn-dbs-pacemaker-puppet.yaml View File

@@ -426,9 +426,6 @@ outputs:
- groups['ovn_dbs'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ ovn_dbs_short_node_names }}"

- debug:
msg: "Prepare ovn_dbs upgrade for {{ ovn_dbs_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade ovn_dbs without staged
@@ -437,7 +434,8 @@ outputs:
when: >-
ovn_dbs_short_node_names_upgraded is not defined or
ovn_dbs_short_node_names_upgraded | length == 0

- debug:
msg: "Prepare ovn_dbs upgrade for {{ ovn_dbs_short_node_names_upgraded }}"
- name: remove ovn_dbs init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 3
deployment/pacemaker/pacemaker-baremetal-puppet.yaml View File

@@ -223,9 +223,6 @@ outputs:
- groups['pacemaker'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ pacemaker_short_node_names }}"

- debug:
msg: "Prepare pacemaker upgrade for {{ pacemaker_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade pacemaker without staged
@@ -234,6 +231,8 @@ outputs:
when: >-
pacemaker_short_node_names_upgraded is not defined or
pacemaker_short_node_names_upgraded | length == 0
- debug:
msg: "Prepare pacemaker upgrade for {{ pacemaker_short_node_names_upgraded }}"
- name: set pacemaker node ips fact from the names fact
set_fact:
# Generate matching IPs for the names, e.g. for these varaible values:

+ 2
- 4
deployment/rabbitmq/rabbitmq-messaging-notify-pacemaker-puppet.yaml View File

@@ -385,9 +385,6 @@ outputs:
- groups['oslo_messaging_notify'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ oslo_messaging_notify_node_names }}"

- debug:
msg: "Prepare oslo_messaging_notify upgrade for {{ oslo_messaging_notify_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade oslo_messaging_notify without
@@ -398,7 +395,8 @@ outputs:
oslo_messaging_notify_short_node_names_upgraded | length == 0 or
oslo_messaging_notify_node_names_upgraded is not defined or
oslo_messaging_notify_node_names_upgraded | length == 0

- debug:
msg: "Prepare oslo_messaging_notify upgrade for {{ oslo_messaging_notify_short_node_names_upgraded }}"
- name: remove rabbitmq init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 4
deployment/rabbitmq/rabbitmq-messaging-pacemaker-puppet.yaml View File

@@ -384,9 +384,6 @@ outputs:
- groups['rabbitmq'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ rabbitmq_short_node_names }}"

- debug:
msg: "Prepare rabbitmq upgrade for {{ rabbitmq_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade rabbitmq without staged
@@ -395,7 +392,8 @@ outputs:
when: >-
rabbitmq_short_node_names_upgraded is not defined or
rabbitmq_short_node_names_upgraded | length == 0

- debug:
msg: "Prepare rabbitmq upgrade for {{ rabbitmq_short_node_names_upgraded }}"
- name: remove rabbitmq init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

+ 2
- 4
deployment/rabbitmq/rabbitmq-messaging-rpc-pacemaker-puppet.yaml View File

@@ -391,9 +391,6 @@ outputs:
- groups['oslo_messaging_rpc'] | length > 1
- item.split('.')[0] in ansible_limit.split(',')
loop: "{{ oslo_messaging_rpc_node_names }}"

- debug:
msg: "Prepare oslo_messaging_rpc upgrade for {{ oslo_messaging_rpc_short_node_names_upgraded }}"
- fail:
msg: >
You can't upgrade oslo_messaging_rpc without
@@ -404,7 +401,8 @@ outputs:
oslo_messaging_rpc_short_node_names_upgraded | length == 0 or
oslo_messaging_rpc_node_names_upgraded is not defined or
oslo_messaging_rpc_node_names_upgraded | length == 0

- debug:
msg: "Prepare oslo_messaging_rpc upgrade for {{ oslo_messaging_rpc_short_node_names_upgraded }}"
- name: remove rabbitmq init container on upgrade-scaleup to force re-init
include_role:
name: tripleo-container-rm

Loading…
Cancel
Save