Browse Source

Merge "Use Ceph cluster name when setting minimum client version" into stable/ussuri

changes/51/775651/1
Zuul 5 months ago
committed by Gerrit Code Review
parent
commit
965c00bf03
  1. 13
      deployment/ceph-ansible/ceph-mon.yaml

13
deployment/ceph-ansible/ceph-mon.yaml

@ -42,6 +42,15 @@ parameters:
type: boolean
default: false
description: Parameter used to trigger the dashboard deployment.
CephClusterName:
type: string
default: ceph
description: The Ceph cluster name.
constraints:
- allowed_pattern: "[a-zA-Z0-9]+"
description: >
The Ceph cluster name must be at least 1 character and contain only
letters and numbers.
conditions:
dashboard_enabled: {equals: [{get_param: CephEnableDashboard}, true]}
@ -123,7 +132,9 @@ outputs:
register: ceph_mon_id
delegate_to: "{{ groups['ceph_mon'][0] }}"
- name: Enforce minimum Ceph clients version to Mimic
command: "{{ container_cli }} exec {{ ceph_mon_id.stdout_lines[0] }} ceph osd set-require-min-compat-client mimic"
command: "{{ container_cli }} exec {{ ceph_mon_id.stdout_lines[0] }} ceph --cluster {{ cluster }} osd set-require-min-compat-client mimic"
delegate_to: "{{ groups['ceph_mon'][0] }}"
vars:
cluster: {get_param: CephClusterName}
external_update_tasks: {get_attr: [CephBase, role_data, external_update_tasks]}
external_upgrade_tasks: {get_attr: [CephBase, role_data, external_upgrade_tasks]}
Loading…
Cancel
Save