Default to cinder v3 in cloud config

Change Ib4f918c01e2fc71eedf7e6c90ca1dc5ccf8ff688 removed the cinder v2
API keystone service and endpoints. However some applications fail to
detect the supported cinder API versions and still default to v2.
See for example how Gophercloud [1] selects which API version to use.

This changes the default cinder API to v3 in the generated cloud config.

[1] https://github.com/gophercloud/utils/blob/6f54843/openstack/clientconfig/requests.go#L902-L918

Change-Id: I3fb719c2b8c92d2aebb76698674ada6b69ad2c8f
changes/77/771977/1
Martin André 2 years ago
parent 5e74ce583b
commit a5383436cb
  1. 1
      deployment/keystone/keystone-container-puppet.yaml

@ -745,6 +745,7 @@ outputs:
- {get_param: PublicTLSCAFile}
- ''
identity_api_version: '3'
volume_api_version: '3'
region_name: {get_param: KeystoneRegion}
- name: Manage Keystone resources
become: true

Loading…
Cancel
Save