Browse Source

Enforces minimum Ceph client version to Mimic

This is so that we can take advantage of the deferred deletion
feature in Cinder.

Change-Id: I4c3d8fee6c7a0c25cca4d1e6b731060684cd28b3
Closes-Bug: 1914124
(cherry picked from commit 8d962f1362)
changes/58/773958/1
Giulio Fidente 6 months ago
parent
commit
fd58e99dec
  1. 17
      deployment/ceph-ansible/ceph-mon.yaml

17
deployment/ceph-ansible/ceph-mon.yaml

@ -108,5 +108,22 @@ outputs:
copy:
dest: "{{playbook_dir}}/ceph-ansible/group_vars/mons.yml"
content: "{{ceph_ansible_group_vars_mons|to_nice_yaml}}"
- - name: ceph_base_external_deploy_finish
# NOTE(gfidente): enforce minimum client version to mimic to use RBD clone v2 with Cinder
when: step|int == 3
become: true
tags:
- ceph
block:
- name: Get ceph-mon container ID
# Supposed to work with cephadm and ceph-ansible formats
# ceph-4b5c8c0a-ff60-454b-a1b4-9747aa737d19-mon.standalone.localdomain
# ceph-mon-standalone
command: "{{ container_cli }} ps -q -f 'name=ceph-?(.*)-mon.*'"
register: ceph_mon_id
delegate_to: "{{ groups['ceph_mon'][0] }}"
- name: Enforce minimum Ceph clients version to Mimic
command: "{{ container_cli }} exec {{ ceph_mon_id.stdout_lines[0] }} ceph osd set-require-min-compat-client mimic"
delegate_to: "{{ groups['ceph_mon'][0] }}"
external_update_tasks: {get_attr: [CephBase, role_data, external_update_tasks]}
external_upgrade_tasks: {get_attr: [CephBase, role_data, external_upgrade_tasks]}
Loading…
Cancel
Save