Browse Source

Bump ansible-lint to 5.3.2

Bump to latest version that fixes issues with rich 11.
We need to fix the linting issues as followup.

Change-Id: Ie9707333454aca755db8daa272e3408ecbbf55da
changes/84/824284/2
rabi 4 months ago
parent
commit
ade61b299f
  1. 7
      .ansible-lint
  2. 17
      .pre-commit-config.yaml

7
.ansible-lint

@ -0,0 +1,7 @@
skip_list:
- role-name
- unnamed-task
- command-instead-of-shell
- no-changed-when
- no-handler
- yaml

17
.pre-commit-config.yaml

@ -25,17 +25,16 @@ repos:
types: [file, yaml]
entry: yamllint --strict -f parsable
- repo: https://github.com/ansible/ansible-lint
rev: v4.3.5
rev: v5.3.2
hooks:
- id: ansible-lint
additional_dependencies:
- 'ansible<2.10'
files: \.(yaml|yml)$
entry: >-
ansible-lint --force-color -v -x "ANSIBLE0006,ANSIBLE0007,ANSIBLE0010,ANSIBLE0012,ANSIBLE0013,ANSIBLE0016" --exclude zuul.d/
# TODO(cloudnull): These codes were added to pass the lint check.
# Things found within roles.galaxy are external
# and not something maintained here.
always_run: true
pass_filenames: false
# do not add file filters here as ansible-lint does not give reliable
# results when called with individual files.
# https://github.com/ansible/ansible-lint/issues/611
verbose: true
entry: env ANSIBLE_LIBRARY=library ansible-lint --force-color -p -v --exclude zuul.d/
- repo: https://github.com/openstack-dev/bashate.git
rev: 0.6.0
hooks:

Loading…
Cancel
Save