Browse Source

Add update roles on several validations.

Review existing validations and update groups when it's useful.

Change-Id: I30a0faeb381e290ac5eb1080c1c1cea0ca2ad5b3
(cherry picked from commit 5bbbd844f9)
changes/15/785615/3
Daniel Bengtsson 2 months ago
committed by Sergii Golovatiuk
parent
commit
042a1451e3
7 changed files with 12 additions and 3 deletions
  1. +1
    -0
      playbooks/container-status.yaml
  2. +2
    -0
      playbooks/openstack-endpoints.yaml
  3. +1
    -0
      playbooks/package-version.yaml
  4. +1
    -0
      playbooks/repos.yaml
  5. +2
    -1
      playbooks/undercloud-heat-purge-deleted.yaml
  6. +3
    -2
      playbooks/undercloud-ipa-server-check.yaml
  7. +2
    -0
      playbooks/undercloud-service-status.yaml

+ 1
- 0
playbooks/container-status.yaml View File

@ -7,6 +7,7 @@
Detect failed containers and raise an error.
groups:
- pre-upgrade
- pre-update
- post-deployment
- post-upgrade
roles:


+ 2
- 0
playbooks/openstack-endpoints.yaml View File

@ -11,5 +11,7 @@
- post-deployment
- pre-upgrade
- post-upgrade
- pre-update
- post-update
roles:
- openstack_endpoints

+ 1
- 0
playbooks/package-version.yaml View File

@ -10,6 +10,7 @@
- prep
- pre-deployment
- pre-upgrade
- pre-update
- pre-system-upgrade
- pre-undercloud-upgrade
- pre-overcloud-prepare


+ 1
- 0
playbooks/repos.yaml View File

@ -12,5 +12,6 @@
Detect if there are any unwanted repositories (such as EPEL) enabled.
groups:
- pre-upgrade
- pre-update
roles:
- repos

+ 2
- 1
playbooks/undercloud-heat-purge-deleted.yaml View File

@ -5,10 +5,11 @@
name: Verify heat-manage purge_deleted is enabled in crontab
description: |
Without a purge_deleted crontab enabled, the
heat database can grow very large. This validation checks that
heat database can grow very large. This validation checks that
the purge_deleted crontab has been set up.
groups:
- pre-upgrade
- pre-update
- pre-deployment
cron_check: "heat-manage purge_deleted"
roles:


+ 3
- 2
playbooks/undercloud-ipa-server-check.yaml View File

@ -8,9 +8,9 @@
This validation is relevant for systems where TLS Everywhere is enabled.
A new ACI is needed on the FreeIPA server to ensure that certificates with IP SANs can be
issued. This ACI will be delivered by default from FreeIPA 4.8.5.
issued. This ACI will be delivered by default from FreeIPA 4.8.5.
In addition, a new permission is needed to add DNS zones for tripleo-ipa. This
In addition, a new permission is needed to add DNS zones for tripleo-ipa. This
permission is an addition to the current permissions for the Nova Host Manager role.
This validation confirms that the new permission and ACI are present.
@ -18,6 +18,7 @@
https://docs.openstack.org/project-deploy-guide/tripleo-docs/latest/features/tls-introduction.html
groups:
- pre-upgrade
- pre-update
tasks:
- include_role:
name: tls_everywhere


+ 2
- 0
playbooks/undercloud-service-status.yaml View File

@ -8,5 +8,7 @@
groups:
- post-upgrade
- pre-upgrade
- post-update
- pre-update
roles:
- undercloud_service_status

Loading…
Cancel
Save