Browse Source

Remove workaround for broken dogpile.cache and lower-constraints file

- dogpile.cache workaround
Bug: https://github.com/sqlalchemy/dogpile.cache/issues/178
Bug: https://bugs.launchpad.net/tripleo/+bug/1876073

- The lower-constraints.txt file has been removed because it is not
useful for TripleO anymore.

Signed-off-by: Gael Chamoulaud (Strider) <gchamoul@redhat.com>
Change-Id: I00e2e252700d0229113cc6ee1c4efff0504fb005
changes/64/765964/4
Gael Chamoulaud (Strider) 2 years ago
parent
commit
b8bb9a5f2c
No known key found for this signature in database
GPG Key ID: 4119D0305C651D66
  1. 5
      .zuul.yaml
  2. 117
      lower-constraints.txt
  3. 2
      molecule-requirements.txt
  4. 5
      test-requirements.txt
  5. 7
      tox.ini

5
.zuul.yaml

@ -19,8 +19,6 @@
- tripleo-multinode-container-minimal-pipeline
- openstack-python3-wallaby-jobs
- tripleo-validations-molecule-jobs
- check-requirements
- openstack-lower-constraints-jobs
- release-notes-jobs-python3
check:
jobs:
@ -32,11 +30,9 @@
- ^molecule-requirements.txt
- ^requirements.txt
- ^README.rst
- openstack-tox-lower-constraints
- tripleo-ci-centos-8-content-provider: &content-provider
dependencies:
- openstack-tox-linters
- openstack-tox-lower-constraints
- tripleo-ci-centos-8-scenario004-standalone: &scenario004
vars: &vars_scen004
consumer_job: true
@ -48,7 +44,6 @@
gate:
jobs:
- openstack-tox-linters
- openstack-tox-lower-constraints
- openstack-tox-docs: *tripleo-docs
- tripleo-ci-centos-8-content-provider: *content-provider
- tripleo-ci-centos-8-scenario004-standalone: *scenario004

117
lower-constraints.txt

@ -1,117 +0,0 @@
alabaster==0.7.10
ansible-lint==3.4.21
ansible==2.4.3.0
anyjson==0.3.3
appdirs==1.4.3
asn1crypto==0.24.0
Babel==2.5.3
bcrypt==3.1.4
certifi==2018.1.18
cffi==1.14.0
chardet==3.0.4
cliff==2.11.0
cmd2==0.8.1
coverage==4.0
cryptography==2.1.4
debtcollector==1.19.0
decorator==4.3.0
deprecation==2.0
docker-pycreds==0.2.2
docker==3.1.1
docutils==0.14
dogpile.cache==0.6.5
dulwich==0.19.0
enum-compat==0.0.2
extras==1.0.0
fasteners==0.14.1
fixtures==3.0.0
flake8==2.5.5
gitdb2==2.0.3
GitPython==2.1.8
greenlet==0.4.15
hacking==0.11.0
idna==2.6
imagesize==1.0.0
iso8601==0.1.12
Jinja2==2.10
jmespath==0.9.3
jsonpatch==1.21
jsonpointer==2.0
jsonschema==3.2.0
keystoneauth1==3.16.0
lxml==4.2.0
linecache2==1.0.0
MarkupSafe==1.1.0
mccabe==0.2.1
mistral-lib==1.2.0
monotonic==1.4
mox3==0.25.0
msgpack==0.5.6
munch==2.2.0
netaddr==0.7.18
netifaces==0.10.6
openstackdocstheme==2.2.1
openstacksdk==0.36.0
os-client-config==1.29.0
os-net-config==7.1.0
os-service-types==1.7.0
osc-lib==2.0.0
oslo.concurrency==3.26.0
oslo.config==5.2.0
oslo.context==2.22.0
oslo.i18n==3.20.0
oslo.log==3.37.0
oslo.serialization==2.25.0
oslo.utils==3.40.2
oslotest==3.2.0
packaging==17.1
paramiko==2.7.1
passlib==1.7.1
pbr==3.1.1
pep8==1.5.7
prettytable==0.7.2
pyasn1==0.4.2
pycparser==2.18
pyflakes==0.8.1
Pygments==2.2.0
pyinotify==0.9.6
PyNaCl==1.2.1
pyOpenSSL==17.5.0
pyparsing==2.2.0
pyperclip==1.6.0
python-dateutil==2.7.0
python-glanceclient==2.9.1
python-heatclient==1.10.0
python-ironic-inspector-client==3.1.1
python-ironicclient==2.7.0
python-keystoneclient==3.22.0
python-mimeparse==1.6.0
python-mistralclient==3.1.0
python-novaclient==15.1.0
python-subunit==1.0.0
python-swiftclient==3.5.0
python-zaqarclient==1.9.0
pytz==2018.3
PyYAML==3.13
reno==3.1.0
requests==2.18.4
requestsexceptions==1.4.0
rfc3986==1.1.0
simplejson==3.13.2
six==1.11.0
smmap2==2.0.3
snowballstemmer==1.2.1
Sphinx==2.0.0
sphinxcontrib-websupport==1.0.1
stevedore==1.28.0
tenacity==5.0.1
testrepository==0.0.18
testscenarios==0.4
testtools==2.2.0
traceback2==1.4.0
tripleo-common==7.1.0
unittest2==1.1.0
urllib3==1.22
warlock==1.3.0
websocket-client==0.47.0
wrapt==1.10.11

2
molecule-requirements.txt

@ -1,8 +1,6 @@
# this is required for the molecule jobs
ansi2html
ansible
# https://github.com/sqlalchemy/dogpile.cache/issues/178
dogpile.cache>=0.6.5,<0.9.1 # MIT
jinja2>=2.8.0,<3
molecule>=3.0,<3.1
pytest

5
test-requirements.txt

@ -3,11 +3,6 @@
# process, which may cause wedges in the gate later.
openstackdocstheme>=2.2.1 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
# remove this pyflakes from here once you bump the
# hacking to 3.2.0 or above. hacking 3.2.0 takes
# care of pyflakes version compatibilty.
pyflakes>=2.1.1
coverage!=4.4,>=4.0 # Apache-2.0
python-subunit>=1.0.0 # Apache-2.0/BSD

7
tox.ini

@ -116,10 +116,3 @@ commands=
# Settings for doc8:
extensions = .rst
ignore = D001
[testenv:lower-constraints]
deps =
-c{toxinidir}/lower-constraints.txt
-r{toxinidir}/test-requirements.txt
-r{toxinidir}/requirements.txt
-r{toxinidir}/molecule-requirements.txt

Loading…
Cancel
Save