Browse Source

molecule-requirements constraints

By placing further constraints on the versions of the
requested packages, we can minimize the time used by
the pip resolver mechanism. [1]

[1](https://github.com/pypa/pip/issues/9215)

Signed-off-by: Jiri Podivin <jpodivin@redhat.com>
Change-Id: I0fc7399cc7fe827e137331cfe11a42d476f6a074
changes/87/800487/2
Jiri Podivin 3 months ago
parent
commit
bb51a0c7e7
  1. 16
      molecule-requirements.txt

16
molecule-requirements.txt

@ -1,12 +1,12 @@
# this is required for the molecule jobs
ansi2html # LGPLv3+
ansi2html>=1.6.0 # LGPLv3+
ansible>=2.8,!=2.8.9,!=2.9.12,<2.10.0 # GPLv3+
jinja2>=2.8.0 # BSD-3-Clause
molecule>=3.3.1,<4 # MIT
molecule-podman # MIT
pytest # MIT
pytest-cov # MIT
pytest-html # Mozilla Public License 2.0
pytest-xdist # MIT
selinux # MIT
lxml # BSD
molecule-podman>=0.3.0 # MIT
pytest>=6.2.4 # MIT
pytest-cov>=2.12.1 # MIT
pytest-html>=3.1.1 # MPL 2.0
pytest-xdist>=2.3.0 # MIT
selinux>=0.2.1 # MIT
lxml>=4.6.3 # BSD
Loading…
Cancel
Save