Browse Source

Normalizing Tripleo Validations metadata

Removed the `description-file` key, it used by flit, but setuptools
which is our packagin lib uses `long_description`[0].

Content type of of readme file was set to 'text/rst-x',
to improve integration with PiPy and provide for possible future changes.

Added framework and development classifiers.[2]

Moved 'python_requires' key into 'options' section where it belongs.[3]

[0] https://setuptools.pypa.io/en/latest/userguide/declarative_config.html?highlight=long_description_content_type#metadata
[1] https://packaging.python.org/en/latest/specifications/core-metadata/#description-content-type
[2] https://pypi.org/classifiers/
[3] https://setuptools.pypa.io/en/latest/userguide/dependency_management.html?highlight=python_requires#python-requirement

Signed-off-by: Jiri Podivin <jpodivin@redhat.com>
Change-Id: I87efcf520c090aed4947c7c1915feecd2c8bf6f2
changes/11/840311/1
Jiri Podivin 3 months ago
parent
commit
befe0ccdac
  1. 10
      setup.cfg

10
setup.cfg

@ -1,14 +1,15 @@
[metadata]
name = tripleo-validations
summary = A collection of Ansible playbooks to detect and report potential issues during TripleO deployments
description_file =
README.rst
long_description = file: README.rst
long_description_content_type = text/rst-x
author = OpenStack
author_email = openstack-discuss@lists.openstack.org
home_page = https://docs.openstack.org/tripleo-validations/latest/
python_requires = >=3.6
classifier =
Development Status :: 5 - Production/Stable
Environment :: OpenStack
Framework :: Ansible
Intended Audience :: Information Technology
Intended Audience :: System Administrators
License :: OSI Approved :: Apache Software License
@ -21,6 +22,9 @@ classifier =
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
[options]
python_requires = >=3.6
[files]
packages =
tripleo_validations

Loading…
Cancel
Save