Browse Source

Bump pre-commit repositories

This patch bumps the following tools:
- pre-commit-hooks[1] to v3.4.0
- yamllint[2] to v1.26.1
- ansible-lint[3] to v5.0.8
- bashate[4] to 2.0.0
- flake8[5] to 3.9.1

[1] - https://github.com/pre-commit/pre-commit-hooks
[2] - https://github.com/adrienverge/yamllint
[3] - https://github.com/ansible-community/ansible-lint
[4] - https://github.com/openstack-dev/bashate
[5] - https://gitlab.com/pycqa/flake8

Signed-off-by: Gael Chamoulaud (Strider) <gchamoul@redhat.com>
Change-Id: I71af534757761cc26e78b4a783687a9810ed8535
changes/35/789835/1
Gael Chamoulaud (Strider) 5 months ago
parent
commit
cdad3a06ab
No known key found for this signature in database GPG Key ID: 4119D0305C651D66
  1. 13
      .pre-commit-config.yaml

13
.pre-commit-config.yaml

@ -1,7 +1,7 @@
---
repos:
- repo: https://github.com/pre-commit/pre-commit-hooks
rev: v2.3.0
rev: v3.4.0
hooks:
- id: end-of-file-fixer
- id: trailing-whitespace
@ -15,28 +15,31 @@ repos:
files: .*\.(yaml|yml)$
- repo: https://gitlab.com/pycqa/flake8
rev: 3.8.3
rev: 3.9.1
hooks:
- id: flake8
additional_dependencies: [flake8-typing-imports==1.6.0]
entry: flake8 --ignore=E24,E121,E122,E123,E124,E126,E226,E265,E305,E402,F401,F405,E501,E704,F403,F841,W503,W605
- repo: https://github.com/adrienverge/yamllint.git
rev: v1.24.2
rev: v1.26.1
hooks:
- id: yamllint
files: \.(yaml|yml)$
types: [file, yaml]
entry: yamllint --strict -f parsable
- repo: https://github.com/ansible/ansible-lint.git
rev: v5.0.3
- repo: https://github.com/ansible-community/ansible-lint
rev: v5.0.8
hooks:
- id: ansible-lint
always_run: true
pass_filenames: false
additional_dependencies:
- 'ansible<2.10'
verbose: true
entry: ansible-lint --force-color -p -v
- repo: https://github.com/openstack-dev/bashate.git
rev: 2.0.0
hooks:

Loading…
Cancel
Save