Browse Source

Fix lower-constraints errors for validations-common

This patch changes the lower-constraint requirements to make them
py3.8 compatible. See https://bugs.launchpad.net/nova/+bug/1886298
cffi==1.14.0
greenlet==0.4.15
MarkupSafe==1.1.0
paramiko==2.7.1
PyYAML==3.13

Change-Id: Id259dccd94a7cc6773e0c2d4002aac08c9557c65
changes/24/751424/1
Mathieu Bultel 2 weeks ago
parent
commit
7f3c565b00
4 changed files with 17 additions and 6 deletions
  1. +7
    -0
      bindep.txt
  2. +5
    -5
      lower-constraints.txt
  3. +1
    -1
      requirements.txt
  4. +4
    -0
      test-requirements.txt

+ 7
- 0
bindep.txt View File

@@ -18,6 +18,13 @@ gcc-c++ [platform:rpm]
git [platform:rpm]
libffi-devel [platform:rpm]
openssl-devel [platform:rpm]

libxml2-dev [platform:dpkg platform:apk]
libxml2-devel [platform:rpm]
libxslt-devel [platform:rpm]
libxslt1-dev [platform:dpkg]
libxslt-dev [platform:apk]

python-devel [platform:rpm !platform:rhel-8 !platform:centos-8]
python3-devel [platform:rpm !platform:rhel-7 !platform:centos-7]
PyYAML [platform:rpm !platform:rhel-8 !platform:centos-8]


+ 5
- 5
lower-constraints.txt View File

@@ -7,7 +7,7 @@ asn1crypto==0.24.0
Babel==2.5.3
bcrypt==3.1.4
certifi==2018.1.18
cffi==1.11.5
cffi==1.14.0
chardet==3.0.4
cliff==2.11.0
cmd2==0.8.1
@@ -29,7 +29,7 @@ fixtures==3.0.0
flake8==2.5.5
gitdb2==2.0.3
GitPython==2.1.8
greenlet==0.4.13
greenlet==0.4.15
hacking==0.11.0
idna==2.6
imagesize==1.0.0
@@ -41,7 +41,7 @@ jsonpointer==2.0
jsonschema==2.6.0
keystoneauth1==3.12.0
linecache2==1.0.0
MarkupSafe==1.0
MarkupSafe==1.1.0
mccabe==0.2.1
mistral-lib==1.2.0
monotonic==1.4
@@ -65,7 +65,7 @@ oslo.serialization==2.25.0
oslo.utils==3.40.2
oslotest==3.2.0
packaging==17.1
paramiko==2.4.1
paramiko==2.7.1
passlib==1.7.1
pbr==3.1.1
pep8==1.5.7
@@ -92,7 +92,7 @@ python-subunit==1.0.0
python-swiftclient==3.5.0
python-zaqarclient==1.9.0
pytz==2018.3
PyYAML==3.12
PyYAML==3.13
reno==2.5.0
requests==2.18.4
requestsexceptions==1.4.0


+ 1
- 1
requirements.txt View File

@@ -3,5 +3,5 @@
# process, which may cause wedges in the gate later.

pbr>=3.1.1 # Apache-2.0
PyYAML>=3.12 # MIT
PyYAML>=3.13 # MIT
PrettyTable>=0.7.2

+ 4
- 0
test-requirements.txt View File

@@ -4,6 +4,10 @@

openstackdocstheme>=1.20.0 # Apache-2.0
hacking>=3.0,<3.1.0 # Apache-2.0
# remove this pyflakes from here once you bump the
# hacking to 3.2.0 or above. hacking 3.2.0 takes
# care of pyflakes version compatibilty.
pyflakes>=2.1.1

coverage!=4.4,>=4.0 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0


Loading…
Cancel
Save