Browse Source

Bump default tox env from py37 to py38

Python 3.8 is now our highest level supported python runtime.
This updates the default tox target environments to swap out
py37 for py38 to make sure local development testing is
covering this version.

This does not impact zuul jobs in any way, nor prevent local
tests against py37. It just changes the default if none is
explicitly provided.

Change-Id: Ia57c69b8433fa3bf8d8edb47441ef737945232cb
Signed-off-by: Sean McGinnis <sean.mcginnis@gmail.com>
changes/12/722912/1
Sean McGinnis 1 year ago
parent
commit
1ee6fa40a8
No known key found for this signature in database GPG Key ID: CE7EE4BFAF8D70C8
  1. 2
      tox.ini

2
tox.ini

@ -1,6 +1,6 @@
[tox]
minversion = 2.0
envlist = linters,py37
envlist = linters,py38
skipdist = True
[testenv]

Loading…
Cancel
Save