Authentication system for the OpenStack Foundation site
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
Sebastian Marcet fbae255e7d Fixed missing npm dependency 11 months ago
app Migrated bower dependencies 1 year ago
bootstrap IDP Upgrade from Laravel 4.X to 5.X 2 years ago
config Updated support email 1 year ago
database Fixed initial DB migrations/seeds 11 months ago
doc/source Correct the openstackid.org URL 3 years ago
public Added cookie disabled warning 1 year ago
resources Fixed missing npm dependency 11 months ago
storage IDP Upgrade from Laravel 4.X to 5.X 2 years ago
tests Fix Access Token reissue with Rotate Refresh Token policy active 1 year ago
.babelrc Migrated bower dependencies to NPM 1 year ago
.env.example Updated support email 1 year ago
.gitattributes IDP Upgrade from Laravel 4.X to 5.X 2 years ago
.gitignore Fixed missing npm dependency 11 months ago
.gitreview Add a .gitreview file 5 years ago
CONTRIBUTING.md [smarcet] - Refs #4590 - Create initial solution and upload to git repo 5 years ago
artisan IDP Upgrade from Laravel 4.X to 5.X 2 years ago
behat.yml OIDC - OpenId Connect Implementation 3 years ago
bindep.txt Move other-requirements.txt to bindep.txt 2 years ago
composer.json IDP Upgrade from Laravel 4.X to 5.X 2 years ago
gulpfile.js IDP Upgrade from Laravel 4.X to 5.X 2 years ago
package-lock.json Fixed missing npm dependency 11 months ago
package.json Fixed missing npm dependency 11 months ago
phpunit.xml IDP Upgrade from Laravel 4.X to 5.X 2 years ago
readme.md IDP Upgrade from Laravel 4.X to 5.X 2 years ago
requirements.txt Add boilerplate for Sphinx doc rendering 4 years ago
server.php IDP Upgrade from Laravel 4.X to 5.X 2 years ago
setup.cfg Pin mockery to a release which supports PHP 5.3 4 years ago
setup.py Add boilerplate for Sphinx doc rendering 4 years ago
tox.ini Add boilerplate for Sphinx doc rendering 4 years ago
webpack.config.js Fixed missing npm dependency 11 months ago

readme.md

OpenstackId Idp

Prerequisites

* LAMP/LEMP environment
* Redis
* PHP >= 5.3.7
* composer (https://getcomposer.org/)

Install

run following commands on root folder

  • curl -s https://getcomposer.org/installer | php
  • php composer.phar install --prefer-dist
  • php composer.phar dump-autoload --optimize
  • php artisan vendor:publish --provider=“Greggilbert\Recaptcha\RecaptchaServiceProvider”
  • php artisan migrate --env=YOUR_ENVIRONMENT
  • php artisan db:seed --env=YOUR_ENVIRONMENT
  • phpunit --bootstrap vendor/autoload.php
  • give proper rights to app/storage folder (775 and proper users)
  • vendor/bin/behat --config /home/smarcet/git/openstackid/behat.yml

Permissions

Laravel may require some permissions to be configured: folders within storage and vendor require write access by the web server.