Browse Source

Replace K8s 1.21.3 with 1.21.8

In testing K8s 1.21.8 used less CPU than 1.21.3, so we are moving to
the newer version.

This has been booted in vbox and a basic pod has been started.
A full regression will be performed.
Still need to install with 1.20 to confirm that we can upgrade to
1.21.8.

Closes-Bug: 1957994
Depends-On: https://review.opendev.org/c/starlingx/integ/+/824803
Depends-On: https://review.opendev.org/c/starlingx/ansible-playbooks/+/824805
Signed-off-by: Chris Friesen <chris.friesen@windriver.com>
Change-Id: I7c6a75ff9bbdddf1bfab3d2ea71a25224293d989
changes/04/824804/2
Chris Friesen 4 months ago
parent
commit
f37403a943
  1. 2
      sysinv/sysinv/sysinv/sysinv/common/kubernetes.py

2
sysinv/sysinv/sysinv/sysinv/common/kubernetes.py

@ -147,7 +147,7 @@ def get_kube_versions():
'applied_patches': [],
'available_patches': [],
},
{'version': 'v1.21.3',
{'version': 'v1.21.8',
'upgrade_from': ['v1.20.9'],
'downgrade_to': [],
'applied_patches': [],

Loading…
Cancel
Save