config/puppet-modules-wrs/puppet-smapi/centos/puppet-smapi.spec
Bin Qian 1268e4aa09 create config for sm-api
1. create smapi service endpoint, credential
2. create sm-api.conf for sm-api configuration
3. configure haproxy, so sm-api binds to mgmt fixed ip, with haproxy:
    mgmt fixed ip -> mgmt floating ip -> oam floating ip

Story: 2002827
Task: 22744

Change-Id: I743f6b0f09c06325d3c9dc6e11902420882e7931
Signed-off-by: Bin Qian <bin.qian@windriver.com>
2018-08-13 13:26:28 -04:00

33 lines
723 B
RPMSpec

%global module_dir smapi
Name: puppet-%{module_dir}
Version: 1.0.0
Release: %{tis_patch_ver}%{?_tis_dist}
Summary: Puppet smapi module
License: Apache-2.0
Packager: Wind River <info@windriver.com>
URL: unknown
Source0: %{name}-%{version}.tar.gz
BuildArch: noarch
BuildRequires: python2-devel
%description
A puppet module for smapi
%prep
%autosetup -c %{module_dir}
#
# The src for this puppet module needs to be staged to puppet/modules
#
%install
install -d -m 0755 %{buildroot}%{_datadir}/puppet/modules/%{module_dir}
cp -R %{name}-%{version}/%{module_dir} %{buildroot}%{_datadir}/puppet/modules
%files
%{_datadir}/puppet/modules/%{module_dir}