Browse Source

Add missing Requires to fault components for opensuse

Some of the fault components rely on having all the dependencies
installed in the StarlingX ISO so having missing dependencies listed
in the spec files is not an issue. However, when we take those compo-
nents and run them in a non StarlingX installation these problems
started to arise.

This patch is the result of the analysis of all imports and a manual
execution of the fault components in opensuse. This is a summary of
the findings:

- fm-api: This component imports `fm_core` which is provided by
          `fm-common` but not listed in the dependencies. Same
          case for `six` module.
- fm-mgr: `fmManager` links to `libfmcommon` but is not listed in the
          requirements. Also, it expects to find the `/etc/fm/events.yaml`
          file which is provided by `fm-doc`.
- fm-rest-api: A set of imports that are missing. This component also
               depends on other StarlingX compoments.
- python-fmclient: Missing python imports.

Story: 2006684
Task: 36971

Change-Id: I6719ab8a8d9a35d105be1c6f7dac57b855da543e
Signed-off-by: Erich Cordoba <erich.cordoba.malibran@intel.com>
changes/38/687438/1
Erich Cordoba 3 years ago
parent
commit
d235681165
  1. 3
      fm-api/opensuse/fm-api.spec
  2. 2
      fm-mgr/opensuse/fm-mgr.spec
  3. 10
      fm-rest-api/opensuse/fm-rest-api.spec
  4. 4
      python-fmclient/opensuse/python-fmclient.spec

3
fm-api/opensuse/fm-api.spec

@ -10,6 +10,9 @@ Source0: %{name}-%{version}.tar.gz
BuildRequires: python-setuptools
BuildRequires: python2-pip
Requires: fm-common
Requires: python2-six
%description
StarlingX platform Fault Management Client Library that provides APIs
for applications to raise/clear/update active alarms.

2
fm-mgr/opensuse/fm-mgr.spec

@ -11,6 +11,8 @@ Source0: %{name}-%{version}.tar.gz
BuildRequires: fm-common-devel
BuildRequires: libuuid-devel
BuildRequires: systemd-devel
Requires: fm-common
Requires: fm-doc
Requires: logrotate
%if 0%{?suse_version}
BuildRequires: gcc-c++

10
fm-rest-api/opensuse/fm-rest-api.spec

@ -17,10 +17,20 @@ BuildRequires: python2-oslo.log
BuildRequires: python2-pip
BuildRequires: systemd
BuildRequires: systemd-rpm-macros
Requires: cgts-client
Requires: python2-oslo.policy
Requires: python2-pecan
Requires: python2-SQLAlchemy
Requires: python2-WSME
Requires: python-oslo.service
Requires: python-oslo.db
Requires: python-oslo.versionedobjects
Requires: python-eventlet
Requires: python-keystonemiddleware
Requires: python-paste
Requires: python-webob
Requires: systemd
Requires: tsconfig
%description
Fault Management Openstack REST API Service

4
python-fmclient/opensuse/python-fmclient.spec

@ -19,6 +19,10 @@ BuildRequires: python-setuptools
BuildRequires: python2-pbr
BuildRequires: python3-pbr
Requires: bash-completion
Requires: python2-httplib2
Requires: python2-pyOpenSSL
Requires: python2-PrettyTable
Requires: python2-python-dateutil
Requires: python-keystoneauth1 >= 3.1.0
Requires: python-oslo.i18n >= 2.1.0
Requires: python-oslo.utils >= 3.20.0

Loading…
Cancel
Save