integ/ostree/ostree-upgrade-mgr/debian/deb_patches/0002-Update-Copyright-and-License.patch
Yue Tao 1ba047c50b ostree: fix several building issues
dh clean
make: dh: No such file or directory
make: *** [debian/rules:4: clean] Error 127

And clean up the Lintian issues, also update
the debian_pkg_dirs

Test Plan: verify initramfs

Pass: successfully build initramfs
Pass: successfully boot using initramfs

Story: 2009221
Task: 43324

Signed-off-by: Yue Tao <yue.tao@windriver.com>
Change-Id: Ifc5fa4e0d5f7273df2e6b0859bc7b3babbb0cf6e
2021-12-01 21:49:59 +08:00

146 lines
5.9 KiB
Diff

From 1917b17c4251e3ecfb2618105c332bb5314e8ad0 Mon Sep 17 00:00:00 2001
From: Yue Tao <yue.tao@windriver.com>
Date: Fri, 19 Nov 2021 06:33:37 +0000
Subject: [PATCH 2/2] Update Copyright and License
Signed-off-by: Yue Tao <yue.tao@windriver.com>
---
debian/control | 22 ++++++++++++++++---
debian/copyright | 56 ++++++++++++++++++------------------------------
debian/rules | 17 +++++++++++++++
3 files changed, 57 insertions(+), 38 deletions(-)
diff --git a/debian/control b/debian/control
index 6c3dbdc..0646522 100644
--- a/debian/control
+++ b/debian/control
@@ -1,11 +1,27 @@
+# Copyright (c) 2021 Wind River Systems, Inc.
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. The ASF licenses this
+# file to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
Source: ostree-upgrade-mgr
Section: admin
Priority: optional
-Maintainer: root <root@3b917021b2df>
+Maintainer: Hongxu Jia <hongxu.jia@windriver.com>
Standards-Version: 4.5.1
-Homepage: https://github.com/WindRiver-Labs/wr-ostree
+Homepage: https://github.com/WindRiver-Labs/meta-lat
Build-Depends: debhelper-compat (= 13)
-Rules-Requires-Root: no
Package: ostree-upgrade-mgr
Architecture: all
diff --git a/debian/copyright b/debian/copyright
index 70db8a4..62352e5 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,43 +1,29 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: ostree-upgrade-mgr
-Upstream-Contact: <preferred name and address to reach the upstream project>
-Source: <url://example.com>
+Upstream-Contact: Hongxu Jia <hongxu.jia@windriver.com>
+Source: https://github.com/Wind-River/meta-lat
Files: *
-Copyright: <years> <put author's name and email here>
- <years> <likewise for another author>
-License: <special license>
- <Put the license of the package here indented by 1 space>
- <This follows the format of Description: lines in control file>
- .
- <Including paragraphs>
+Copyright: Copyright (c) 2021 Wind River
+License: MIT-License
-# If you want to use GPL v2 or later for the /debian/* files use
-# the following clauses, or change it to suit. Delete these two lines
-Files: debian/*
-Copyright: 2021 root <root@3b917021b2df>
-License: GPL-2+
- This package is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2 of the License, or
- (at your option) any later version.
+License: MIT-License
+ Copyright (c) 2021 Wind River
.
- This package is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
.
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <https://www.gnu.org/licenses/>
+ The above copyright notice and this permission notice shall be included in all
+ copies or substantial portions of the Software.
.
- On Debian systems, the complete text of the GNU General
- Public License version 2 can be found in "/usr/share/common-licenses/GPL-2".
-
-# Please also look if there are files or directories which have a
-# different copyright/license attached and list them here.
-# Please avoid picking licenses with terms that are more restrictive than the
-# packaged work, as it may make Debian's contributions unacceptable upstream.
-#
-# If you need, there are some extra license texts available in two places:
-# /usr/share/debhelper/dh_make/licenses/
-# /usr/share/common-licenses/
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ SOFTWARE.
diff --git a/debian/rules b/debian/rules
index 9f9252e..e4cf8c9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,21 @@
#!/usr/bin/make -f
+#
+# Copyright (c) 2021 Wind River Systems, Inc.
+#
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. The ASF licenses this
+# file to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
%:
dh $@
--
2.30.2