monitor-helm-elastic: set PATCHTOOL Remove do_patch override

Signed-off-by: Babak Sarashki <Babak.SarAshki@windriver.com>
This commit is contained in:
Babak Sarashki 2020-07-15 11:55:40 -07:00
parent 126bf3a758
commit 86c5c5751c
8 changed files with 878 additions and 16 deletions

View File

@ -0,0 +1,62 @@
From c9c3e8ff214360eb2e5d9e7728b7bee8fe771eea Mon Sep 17 00:00:00 2001
From: Kevin Smith <kevin.smith@windriver.com>
Date: Tue, 1 Oct 2019 15:25:32 -0400
Subject: [PATCH 1/1] add makefile
---
Makefile | 43 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)
create mode 100644 Makefile
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..5cf4447
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright 2017 The Openstack-Helm Authors.
+#
+# Copyright (c) 2018 Wind River Systems, Inc.
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+# It's necessary to set this because some environments don't link sh -> bash.
+SHELL := /bin/bash
+TASK := build
+
+EXCLUDES := helm-toolkit doc tests tools logs tmp
+CHARTS := helm-toolkit $(filter-out $(EXCLUDES), $(patsubst %/.,%,$(wildcard */.)))
+
+.PHONY: $(EXCLUDES) $(CHARTS)
+
+all: $(CHARTS)
+
+$(CHARTS):
+ @if [ -d $@ ]; then \
+ echo; \
+ echo "===== Processing [$@] chart ====="; \
+ make $(TASK)-$@; \
+ fi
+
+init-%:
+ if [ -f $*/Makefile ]; then make -C $*; fi
+ if [ -f $*/requirements.yaml ]; then helm dep up $*; fi
+
+lint-%: init-%
+ if [ -d $* ]; then helm lint $*; fi
+
+build-%: lint-%
+ if [ -d $* ]; then helm package $*; fi
+
+clean:
+ @echo "Clean all build artifacts"
+ rm -f */templates/_partials.tpl */templates/_globals.tpl
+ rm -f *tgz */charts/*tgz */requirements.lock
+ rm -rf */charts */tmpcharts
+
+%:
+ @:
--
1.8.3.1

View File

@ -0,0 +1,68 @@
From f79169b8e6a57881952ca4d2c338eeda179471e9 Mon Sep 17 00:00:00 2001
From: Kevin Smith <kevin.smith@windriver.com>
Date: Mon, 7 Oct 2019 11:18:05 -0400
Subject: [PATCH 1/1] Add compatibility for k8s 1.16
---
elasticsearch/templates/_helpers.tpl | 22 ++++++++++++++++++++++
elasticsearch/templates/ingress.yaml | 2 +-
elasticsearch/templates/statefulset.yaml | 2 +-
3 files changed, 24 insertions(+), 2 deletions(-)
diff --git a/elasticsearch/templates/_helpers.tpl b/elasticsearch/templates/_helpers.tpl
index d651d56..ccfd8c3 100755
--- a/elasticsearch/templates/_helpers.tpl
+++ b/elasticsearch/templates/_helpers.tpl
@@ -47,3 +47,25 @@ We truncate at 63 chars because some Kubernetes name fields are limited to this
{{- end -}}
{{- end -}}
{{- end -}}
+
+{{/*
+Return the appropriate apiVersion for statefulset.
+*/}}
+{{- define "elasticsearch.statefulset.apiVersion" -}}
+{{- if semverCompare "<1.9-0" .Capabilities.KubeVersion.GitVersion -}}
+{{- print "apps/v1beta2" -}}
+{{- else -}}
+{{- print "apps/v1" -}}
+{{- end -}}
+{{- end -}}
+
+{{/*
+Return the appropriate apiVersion for ingress.
+*/}}
+{{- define "elasticsearch.ingress.apiVersion" -}}
+{{- if semverCompare "<1.14-0" .Capabilities.KubeVersion.GitVersion -}}
+{{- print "extensions/v1beta1" -}}
+{{- else -}}
+{{- print "networking.k8s.io/v1beta1" -}}
+{{- end -}}
+{{- end -}}
diff --git a/elasticsearch/templates/ingress.yaml b/elasticsearch/templates/ingress.yaml
index 39167ca..1715b97 100644
--- a/elasticsearch/templates/ingress.yaml
+++ b/elasticsearch/templates/ingress.yaml
@@ -2,7 +2,7 @@
{{- $fullName := include "uname" . -}}
{{- $servicePort := .Values.httpPort -}}
{{- $ingressPath := .Values.ingress.path -}}
-apiVersion: extensions/v1beta1
+apiVersion: {{ template "elasticsearch.ingress.apiVersion" . }}
kind: Ingress
metadata:
name: {{ $fullName }}
diff --git a/elasticsearch/templates/statefulset.yaml b/elasticsearch/templates/statefulset.yaml
index 004578f..36c7af6 100644
--- a/elasticsearch/templates/statefulset.yaml
+++ b/elasticsearch/templates/statefulset.yaml
@@ -1,5 +1,5 @@
---
-apiVersion: apps/v1beta1
+apiVersion: {{ template "elasticsearch.statefulset.apiVersion" . }}
kind: StatefulSet
metadata:
name: {{ template "uname" . }}
--
1.8.3.1

View File

@ -0,0 +1,25 @@
From a1ea0a2f488660f9cfbab44a4fb8b163e135ebf5 Mon Sep 17 00:00:00 2001
From: Kevin Smith <kevin.smith@windriver.com>
Date: Tue, 8 Oct 2019 13:35:57 -0400
Subject: [PATCH 1/1] use oss image
---
elasticsearch/values.yaml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/elasticsearch/values.yaml b/elasticsearch/values.yaml
index ccab462..f4fca1f 100755
--- a/elasticsearch/values.yaml
+++ b/elasticsearch/values.yaml
@@ -42,7 +42,7 @@ secretMounts: []
# secretName: elastic-certificates
# path: /usr/share/elasticsearch/config/certs
-image: "docker.elastic.co/elasticsearch/elasticsearch"
+image: "docker.elastic.co/elasticsearch/elasticsearch-oss"
imageTag: "7.3.2"
imagePullPolicy: "IfNotPresent"
--
1.8.3.1

View File

@ -0,0 +1,649 @@
From 560555d13b524eb5209ab42144a3d40989cc2ac7 Mon Sep 17 00:00:00 2001
From: John Kung <john.kung@windriver.com>
Date: Tue, 15 Oct 2019 12:56:39 -0400
Subject: [PATCH 1/1] Update to Elastic 7.4.0 Release
---
CHANGELOG.md | 45 ++++++++++++++++++++--
elasticsearch/Chart.yaml | 4 +-
elasticsearch/README.md | 8 ++--
elasticsearch/examples/default/test/goss.yaml | 2 +-
elasticsearch/examples/openshift/test/goss.yaml | 2 +-
elasticsearch/examples/oss/test/goss.yaml | 2 +-
elasticsearch/examples/upgrade/test/goss.yaml | 2 +-
elasticsearch/values.yaml | 2 +-
filebeat/Chart.yaml | 4 +-
filebeat/README.md | 8 ++--
filebeat/examples/default/test/goss.yaml | 4 +-
filebeat/examples/oss/test/goss.yaml | 2 +-
filebeat/examples/security/test/goss.yaml | 2 +-
filebeat/values.yaml | 2 +-
helpers/bumper.py | 4 +-
helpers/examples.mk | 2 +-
kibana/Chart.yaml | 4 +-
kibana/README.md | 8 ++--
kibana/examples/default/test/goss.yaml | 2 +-
kibana/values.yaml | 2 +-
metricbeat/Chart.yaml | 4 +-
metricbeat/README.md | 8 ++--
metricbeat/examples/default/test/goss-metrics.yaml | 6 +--
metricbeat/examples/default/test/goss.yaml | 6 +--
metricbeat/examples/oss/test/goss-metrics.yaml | 6 +--
metricbeat/examples/oss/test/goss.yaml | 6 +--
.../examples/security/test/goss-metrics.yaml | 6 +--
metricbeat/examples/security/test/goss.yaml | 6 +--
metricbeat/values.yaml | 2 +-
29 files changed, 99 insertions(+), 62 deletions(-)
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 250d11a..bb2fc24 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,9 +1,46 @@
# Changelog
+## 7.4.0 - 2019/10/01
+
+* 7.4.0 as the default stack version
+* Helm-tester Docker image migrated to Python 3 in [#297](https://github.com/elastic/helm-charts/pull/297) [@jmlrt](https://github.com/jmlrt)
+* Helm-tester Python dependencies freeze in [#309](https://github.com/elastic/helm-charts/pull/309) [@jmlrt](https://github.com/jmlrt)
+
+### Elasticsearch
+
+| PR | Author | Title |
+| ------------------------------------------------------- | -------------------------------------------------- | ----------------------------------------------------------------------------------- |
+|[#296](https://github.com/elastic/helm-charts/pull/296) | [@jmlrt](https://github.com/jmlrt) | Fix "; \" when there is no additional command in the Makefiles |
+|[#298](https://github.com/elastic/helm-charts/pull/298) | [@floretan](https://github.com/floretan) | Make it possible to override the endpoint template. |
+|[#263](https://github.com/elastic/helm-charts/pull/263) | [@Crazybus](https://github.com/Crazybus) | Add working examples for running Elasticsearch and Kibana on OpenShift |
+|[#301](https://github.com/elastic/helm-charts/pull/301) | [@ravishivt](https://github.com/ravishivt) | Fix bug in keystore initContainer |
+
+### Kibana
+
+| PR | Author | Title |
+| ------------------------------------------------------- | -------------------------------------------------- | ----------------------------------------------------------------------------------- |
+|[#295](https://github.com/elastic/helm-charts/pull/295) | [@karlbohlmark](https://github.com/karlbohlmark) | Allow configuring lifecycle events |
+|[#263](https://github.com/elastic/helm-charts/pull/263) | [@Crazybus](https://github.com/Crazybus) | Add working examples for running Elasticsearch and Kibana on OpenShift |
+|[#303](https://github.com/elastic/helm-charts/pull/303) | [@code-chris](https://github.com/code-chris) | Add compatibility for k8s 1.16 and change min k8s version due to ingress apiVersion |
+
+
+### Filebeat
+
+| PR | Author | Title |
+| ------------------------------------------------------- | -------------------------------------------------- | ----------------------------------------------------------------------------------- |
+|[#304](https://github.com/elastic/helm-charts/pull/304) | [@code-chris](https://github.com/code-chris) | Change min k8s version due to daemonset apiVersion |
+
+### Metricbeat
+
+| PR | Author | Title |
+| ------------------------------------------------------- | -------------------------------------------------- | ----------------------------------------------------------------------------------- |
+|[#305](https://github.com/elastic/helm-charts/pull/305) | [@code-chris](https://github.com/code-chris) | Change min k8s version due to used apiVersions |
+
+
## 7.3.2 - 2019/09/19
* 7.3.2 as the default stack version
-* Testing of GKE for 1.11 dropped and 1.14 added [#287](https://github.com/elastic/helm-charts/pull/287))
+* Testing of GKE for 1.11 dropped and 1.14 added [#287](https://github.com/elastic/helm-charts/pull/287)
* Make helper scripts python3 compatible [#255](https://github.com/elastic/helm-charts/pull/255) [@cclauss](https://github.com/cclauss)
### Elasticsearch
@@ -176,14 +213,14 @@
### Elasticsearch
-* [#100](https://github.com/elastic/helm-charts/pull/100) - @kuisathaverat - Remove deprecated zen ping unicast hosts setting
+* [#100](https://github.com/elastic/helm-charts/pull/100) - @kuisathaverat - Remove deprecated zen ping unicast hosts setting
* [#114](https://github.com/elastic/helm-charts/pull/114) - @Crazybus - Make persistent volumes optional
* [#115](https://github.com/elastic/helm-charts/pull/115) - @Crazybus - Added an integration test for upgrading from the previous release and testing rolling upgrades
### Kibana
-* [#107](https://github.com/elastic/helm-charts/pull/107) - @Crazybus - Make the health check path configurable to support webroots and other customizations.
+* [#107](https://github.com/elastic/helm-charts/pull/107) - @Crazybus - Make the health check path configurable to support webroots and other customizations.
---
## 7.0.0-alpha1 - 2019/04/17
@@ -203,7 +240,7 @@ esMajorVersion: 6
imageTag: 6.7.1
```
-If you are upgrading an existing cluster that did not override the default `storageClassName` you will now need to specify the `storageClassName`. This only affects existing clusters and was changed in https://github.com/elastic/helm-charts/pull/94. The advantage of this is that now the helm chart will just use the default storageClassName rather than needing to override it for any providers where it is not called `standard`.
+If you are upgrading an existing cluster that did not override the default `storageClassName` you will now need to specify the `storageClassName`. This only affects existing clusters and was changed in https://github.com/elastic/helm-charts/pull/94. The advantage of this is that now the helm chart will just use the default storageClassName rather than needing to override it for any providers where it is not called `standard`.
```
volumeClaimTemplate:
diff --git a/elasticsearch/Chart.yaml b/elasticsearch/Chart.yaml
index cfb40d8..e9d5d24 100755
--- a/elasticsearch/Chart.yaml
+++ b/elasticsearch/Chart.yaml
@@ -4,8 +4,8 @@ maintainers:
- email: helm-charts@elastic.co
name: Elastic
name: elasticsearch
-version: 7.3.2
-appVersion: 7.3.2
+version: 7.4.0
+appVersion: 7.4.0
sources:
- https://github.com/elastic/elasticsearch
icon: https://helm.elastic.co/icons/elasticsearch.png
diff --git a/elasticsearch/README.md b/elasticsearch/README.md
index ff90f09..ab9fe7f 100644
--- a/elasticsearch/README.md
+++ b/elasticsearch/README.md
@@ -43,14 +43,14 @@ This chart is tested with the latest supported versions. The currently tested ve
| 6.x | 7.x |
| ----- | ----- |
-| 6.8.3 | 7.3.2 |
+| 6.8.3 | 7.4.0 |
Examples of installing older major versions can be found in the [examples](./examples) directory.
-While only the latest releases are tested, it is possible to easily install old or new releases by overriding the `imageTag`. To install version `7.3.2` of Elasticsearch it would look like this:
+While only the latest releases are tested, it is possible to easily install old or new releases by overriding the `imageTag`. To install version `7.4.0` of Elasticsearch it would look like this:
```
-helm install --name elasticsearch elastic/elasticsearch --set imageTag=7.3.2
+helm install --name elasticsearch elastic/elasticsearch --set imageTag=7.4.0
```
## Configuration
@@ -71,7 +71,7 @@ helm install --name elasticsearch elastic/elasticsearch --set imageTag=7.3.2
| `extraInitContainers` | Templatable string of additional init containers to be passed to the `tpl` function | `""` |
| `secretMounts` | Allows you easily mount a secret as a file inside the statefulset. Useful for mounting certificates and other secrets. See [values.yaml](./values.yaml) for an example | `[]` |
| `image` | The Elasticsearch docker image | `docker.elastic.co/elasticsearch/elasticsearch` |
-| `imageTag` | The Elasticsearch docker image tag | `7.3.2` |
+| `imageTag` | The Elasticsearch docker image tag | `7.4.0` |
| `imagePullPolicy` | The Kubernetes [imagePullPolicy](https://kubernetes.io/docs/concepts/containers/images/#updating-images) value | `IfNotPresent` |
| `podAnnotations` | Configurable [annotations](https://kubernetes.io/docs/concepts/overview/working-with-objects/annotations/) applied to all Elasticsearch pods | `{}` |
| `labels` | Configurable [label](https://kubernetes.io/docs/concepts/overview/working-with-objects/labels/) applied to all Elasticsearch pods | `{}` |
diff --git a/elasticsearch/examples/default/test/goss.yaml b/elasticsearch/examples/default/test/goss.yaml
index 182981d..49b1994 100644
--- a/elasticsearch/examples/default/test/goss.yaml
+++ b/elasticsearch/examples/default/test/goss.yaml
@@ -15,7 +15,7 @@ http:
status: 200
timeout: 2000
body:
- - '"number" : "7.3.2"'
+ - '"number" : "7.4.0"'
- '"cluster_name" : "elasticsearch"'
- '"name" : "elasticsearch-master-0"'
- 'You Know, for Search'
diff --git a/elasticsearch/examples/openshift/test/goss.yaml b/elasticsearch/examples/openshift/test/goss.yaml
index 275754b..3a7a1b0 100644
--- a/elasticsearch/examples/openshift/test/goss.yaml
+++ b/elasticsearch/examples/openshift/test/goss.yaml
@@ -11,7 +11,7 @@ http:
status: 200
timeout: 2000
body:
- - '"number" : "7.3.0"'
+ - '"number" : "7.4.0"'
- '"cluster_name" : "elasticsearch"'
- '"name" : "elasticsearch-master-0"'
- 'You Know, for Search'
diff --git a/elasticsearch/examples/oss/test/goss.yaml b/elasticsearch/examples/oss/test/goss.yaml
index 21e268b..1eec5a8 100644
--- a/elasticsearch/examples/oss/test/goss.yaml
+++ b/elasticsearch/examples/oss/test/goss.yaml
@@ -11,7 +11,7 @@ http:
status: 200
timeout: 2000
body:
- - '"number" : "7.3.2"'
+ - '"number" : "7.4.0"'
- '"cluster_name" : "oss"'
- '"name" : "oss-master-0"'
- 'You Know, for Search'
diff --git a/elasticsearch/examples/upgrade/test/goss.yaml b/elasticsearch/examples/upgrade/test/goss.yaml
index 5e20f7f..f7dbf10 100644
--- a/elasticsearch/examples/upgrade/test/goss.yaml
+++ b/elasticsearch/examples/upgrade/test/goss.yaml
@@ -11,7 +11,7 @@ http:
status: 200
timeout: 2000
body:
- - '"number" : "7.3.2"'
+ - '"number" : "7.4.0"'
- '"cluster_name" : "upgrade"'
- '"name" : "upgrade-master-0"'
- 'You Know, for Search'
diff --git a/elasticsearch/values.yaml b/elasticsearch/values.yaml
index f4fca1f..6175540 100755
--- a/elasticsearch/values.yaml
+++ b/elasticsearch/values.yaml
@@ -43,7 +43,7 @@ secretMounts: []
# path: /usr/share/elasticsearch/config/certs
image: "docker.elastic.co/elasticsearch/elasticsearch-oss"
-imageTag: "7.3.2"
+imageTag: "7.4.0"
imagePullPolicy: "IfNotPresent"
podAnnotations: {}
diff --git a/filebeat/Chart.yaml b/filebeat/Chart.yaml
index 59d7ebe..42cffb3 100755
--- a/filebeat/Chart.yaml
+++ b/filebeat/Chart.yaml
@@ -4,8 +4,8 @@ maintainers:
- email: helm-charts@elastic.co
name: Elastic
name: filebeat
-version: 7.3.2
-appVersion: 7.3.2
+version: 7.4.0
+appVersion: 7.4.0
sources:
- https://github.com/elastic/beats
icon: https://helm.elastic.co/icons/filebeat.png
diff --git a/filebeat/README.md b/filebeat/README.md
index 901515d..5b56ca1 100644
--- a/filebeat/README.md
+++ b/filebeat/README.md
@@ -30,14 +30,14 @@ This chart is tested with the latest supported versions. The currently tested ve
| 6.x | 7.x |
| ----- | ----- |
-| 6.8.3 | 7.3.2 |
+| 6.8.3 | 7.4.0 |
Examples of installing older major versions can be found in the [examples](./examples) directory.
-While only the latest releases are tested, it is possible to easily install old or new releases by overriding the `imageTag`. To install version `7.3.2` of Filebeat it would look like this:
+While only the latest releases are tested, it is possible to easily install old or new releases by overriding the `imageTag`. To install version `7.4.0` of Filebeat it would look like this:
```
-helm install --name filebeat elastic/filebeat --set imageTag=7.3.2
+helm install --name filebeat elastic/filebeat --set imageTag=7.4.0
```
@@ -50,7 +50,7 @@ helm install --name filebeat elastic/filebeat --set imageTag=7.3.2
| `extraVolumes` | Templatable string of additional volumes to be passed to the `tpl` function | `""` |
| `hostPathRoot` | Fully-qualified [hostPath](https://kubernetes.io/docs/concepts/storage/volumes/#hostpath) that will be used to persist Filebeat registry data | `/var/lib` |
| `image` | The Filebeat docker image | `docker.elastic.co/beats/filebeat` |
-| `imageTag` | The Filebeat docker image tag | `7.3.2` |
+| `imageTag` | The Filebeat docker image tag | `7.4.0` |
| `imagePullPolicy` | The Kubernetes [imagePullPolicy](https://kubernetes.io/docs/concepts/containers/images/#updating-images) value | `IfNotPresent` |
| `imagePullSecrets` | Configuration for [imagePullSecrets](https://kubernetes.io/docs/tasks/configure-pod-container/pull-image-private-registry/#create-a-pod-that-uses-your-secret) so that you can use a private registry for your image | `[]` |
| `managedServiceAccount` | Whether the `serviceAccount` should be managed by this helm chart. Set this to `false` in order to manage your own service account and related roles. | `true` |
diff --git a/filebeat/examples/default/test/goss.yaml b/filebeat/examples/default/test/goss.yaml
index ea0ca18..6713348 100644
--- a/filebeat/examples/default/test/goss.yaml
+++ b/filebeat/examples/default/test/goss.yaml
@@ -29,7 +29,7 @@ http:
status: 200
timeout: 2000
body:
- - 'filebeat-7.3.2'
+ - 'filebeat-7.4.0'
file:
/usr/share/filebeat/filebeat.yml:
@@ -44,4 +44,4 @@ command:
exit-status: 0
stdout:
- 'elasticsearch: http://elasticsearch-master:9200'
- - 'version: 7.3.2'
+ - 'version: 7.4.0'
diff --git a/filebeat/examples/oss/test/goss.yaml b/filebeat/examples/oss/test/goss.yaml
index cf9d0a9..f38cbfe 100644
--- a/filebeat/examples/oss/test/goss.yaml
+++ b/filebeat/examples/oss/test/goss.yaml
@@ -19,4 +19,4 @@ http:
status: 200
timeout: 2000
body:
- - 'filebeat-7.3.2'
+ - 'filebeat-7.4.0'
diff --git a/filebeat/examples/security/test/goss.yaml b/filebeat/examples/security/test/goss.yaml
index f5efc42..a7ef6c3 100644
--- a/filebeat/examples/security/test/goss.yaml
+++ b/filebeat/examples/security/test/goss.yaml
@@ -3,7 +3,7 @@ http:
status: 200
timeout: 2000
body:
- - 'filebeat-7.3.2'
+ - 'filebeat-7.4.0'
allow-insecure: true
username: '{{ .Env.ELASTICSEARCH_USERNAME }}'
password: '{{ .Env.ELASTICSEARCH_PASSWORD }}'
diff --git a/filebeat/values.yaml b/filebeat/values.yaml
index 284185a..1e6af75 100755
--- a/filebeat/values.yaml
+++ b/filebeat/values.yaml
@@ -34,7 +34,7 @@ extraVolumes: ""
hostPathRoot: /var/lib
image: "docker.elastic.co/beats/filebeat"
-imageTag: "7.3.2"
+imageTag: "7.4.0"
imagePullPolicy: "IfNotPresent"
imagePullSecrets: []
diff --git a/helpers/bumper.py b/helpers/bumper.py
index c1cf2a8..5d4f0d6 100755
--- a/helpers/bumper.py
+++ b/helpers/bumper.py
@@ -7,11 +7,11 @@ import fileinput
os.chdir(os.path.join(os.path.dirname(__file__), '..'))
-chart_version = '7.3.2'
+chart_version = '7.4.0'
versions = {
6: '6.8.3',
- 7: '7.3.2',
+ 7: '7.4.0',
}
file_patterns = [
diff --git a/helpers/examples.mk b/helpers/examples.mk
index 9a429f8..56f749c 100644
--- a/helpers/examples.mk
+++ b/helpers/examples.mk
@@ -1,7 +1,7 @@
GOSS_VERSION := v0.3.6
GOSS_FILE ?= goss.yaml
GOSS_SELECTOR ?= release=$(RELEASE)
-STACK_VERSION := 7.3.2
+STACK_VERSION := 7.4.0
goss:
GOSS_CONTAINER=$$(kubectl get --no-headers=true pods -l $(GOSS_SELECTOR) -o custom-columns=:metadata.name | sed -n 1p ) && \
diff --git a/kibana/Chart.yaml b/kibana/Chart.yaml
index 2754b57..d858b0a 100755
--- a/kibana/Chart.yaml
+++ b/kibana/Chart.yaml
@@ -4,8 +4,8 @@ maintainers:
- email: helm-charts@elastic.co
name: Elastic
name: kibana
-version: 7.3.2
-appVersion: 7.3.2
+version: 7.4.0
+appVersion: 7.4.0
sources:
- https://github.com/elastic/kibana
icon: https://helm.elastic.co/icons/kibana.png
diff --git a/kibana/README.md b/kibana/README.md
index ef30957..6f2cf2e 100644
--- a/kibana/README.md
+++ b/kibana/README.md
@@ -26,14 +26,14 @@ This chart is tested with the latest supported versions. The currently tested ve
| 6.x | 7.x |
| ----- | ----- |
-| 6.8.3 | 7.3.2 |
+| 6.8.3 | 7.4.0 |
Examples of installing older major versions can be found in the [examples](./examples) directory.
-While only the latest releases are tested, it is possible to easily install old or new releases by overriding the `imageTag`. To install version `7.3.2` of Kibana it would look like this:
+While only the latest releases are tested, it is possible to easily install old or new releases by overriding the `imageTag`. To install version `7.4.0` of Kibana it would look like this:
```
-helm install --name kibana elastic/kibana --set imageTag=7.3.2
+helm install --name kibana elastic/kibana --set imageTag=7.4.0
```
## Configuration
@@ -46,7 +46,7 @@ helm install --name kibana elastic/kibana --set imageTag=7.3.2
| `extraEnvs` | Extra [environment variables](https://kubernetes.io/docs/tasks/inject-data-application/define-environment-variable-container/#using-environment-variables-inside-of-your-config) which will be appended to the `env:` definition for the container | `[]` |
| `secretMounts` | Allows you easily mount a secret as a file inside the deployment. Useful for mounting certificates and other secrets. See [values.yaml](./values.yaml) for an example | `[]` |
| `image` | The Kibana docker image | `docker.elastic.co/kibana/kibana` |
-| `imageTag` | The Kibana docker image tag | `7.3.2` |
+| `imageTag` | The Kibana docker image tag | `7.4.0` |
| `imagePullPolicy` | The Kubernetes [imagePullPolicy](https://kubernetes.io/docs/concepts/containers/images/#updating-images) value | `IfNotPresent` |
| `podAnnotations` | Configurable [annotations](https://kubernetes.io/docs/concepts/overview/working-with-objects/annotations/) applied to all Kibana pods | `{}` |
| `resources` | Allows you to set the [resources](https://kubernetes.io/docs/concepts/configuration/manage-compute-resources-container/) for the statefulset | `requests.cpu: 100m`<br>`requests.memory: 500Mi`<br>`limits.cpu: 1000m`<br>`limits.memory: 2Gi` |
diff --git a/kibana/examples/default/test/goss.yaml b/kibana/examples/default/test/goss.yaml
index 760d38a..2bafc00 100644
--- a/kibana/examples/default/test/goss.yaml
+++ b/kibana/examples/default/test/goss.yaml
@@ -3,7 +3,7 @@ http:
status: 200
timeout: 2000
body:
- - '"number":"7.3.2"'
+ - '"number":"7.4.0"'
http://localhost:5601/app/kibana:
status: 200
diff --git a/kibana/values.yaml b/kibana/values.yaml
index 1af52b8..4e3668c 100755
--- a/kibana/values.yaml
+++ b/kibana/values.yaml
@@ -22,7 +22,7 @@ secretMounts: []
# subPath: kibana.keystore # optional
image: "docker.elastic.co/kibana/kibana"
-imageTag: "7.3.2"
+imageTag: "7.4.0"
imagePullPolicy: "IfNotPresent"
# additionals labels
diff --git a/metricbeat/Chart.yaml b/metricbeat/Chart.yaml
index 569d47c..d6f0f4b 100755
--- a/metricbeat/Chart.yaml
+++ b/metricbeat/Chart.yaml
@@ -4,8 +4,8 @@ maintainers:
- email: helm-charts@elastic.co
name: Elastic
name: metricbeat
-version: 7.3.2
-appVersion: 7.3.2
+version: 7.4.0
+appVersion: 7.4.0
sources:
- https://github.com/elastic/beats
icon: https://helm.elastic.co/icons/metricbeat.png
diff --git a/metricbeat/README.md b/metricbeat/README.md
index 1e53f47..ecca6f4 100644
--- a/metricbeat/README.md
+++ b/metricbeat/README.md
@@ -26,14 +26,14 @@ This chart is tested with the latest supported versions. The currently tested ve
| 6.x | 7.x |
| ----- | ----- |
-| 6.8.3 | 7.3.2 |
+| 6.8.3 | 7.4.0 |
Examples of installing older major versions can be found in the [examples](./examples) directory.
-While only the latest releases are tested, it is possible to easily install old or new releases by overriding the `imageTag`. To install version `7.3.2` of metricbeat it would look like this:
+While only the latest releases are tested, it is possible to easily install old or new releases by overriding the `imageTag`. To install version `7.4.0` of metricbeat it would look like this:
```
-helm install --name metricbeat elastic/metricbeat --set imageTag=7.3.2
+helm install --name metricbeat elastic/metricbeat --set imageTag=7.4.0
```
@@ -46,7 +46,7 @@ helm install --name metricbeat elastic/metricbeat --set imageTag=7.3.2
| `extraVolumes` | Templatable string of additional volumes to be passed to the `tpl` function | `""` |
| `hostPathRoot` | Fully-qualified [hostPath](https://kubernetes.io/docs/concepts/storage/volumes/#hostpath) that will be used to persist Metricbeat registry data | `/var/lib` |
| `image` | The Metricbeat docker image | `docker.elastic.co/beats/metricbeat` |
-| `imageTag` | The Metricbeat docker image tag | `7.3.2` |
+| `imageTag` | The Metricbeat docker image tag | `7.4.0` |
| `imagePullPolicy` | The Kubernetes [imagePullPolicy](https://kubernetes.io/docs/concepts/containers/images/#updating-images) value | `IfNotPresent` |
| `imagePullSecrets` | Configuration for [imagePullSecrets](https://kubernetes.io/docs/tasks/configure-pod-container/pull-image-private-registry/#create-a-pod-that-uses-your-secret) so that you can use a private registry for your image | `[]` |
| `managedServiceAccount` | Whether the `serviceAccount` should be managed by this helm chart. Set this to `false` in order to manage your own service account and related roles. | `true` |
diff --git a/metricbeat/examples/default/test/goss-metrics.yaml b/metricbeat/examples/default/test/goss-metrics.yaml
index 3e0304d..b4e5163 100644
--- a/metricbeat/examples/default/test/goss-metrics.yaml
+++ b/metricbeat/examples/default/test/goss-metrics.yaml
@@ -21,13 +21,13 @@ http:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
'http://elasticsearch-master:9200/_search?q=metricset.name:state_container%20AND%20kubernetes.container.name:metricbeat':
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
file:
/usr/share/metricbeat/metricbeat.yml:
@@ -42,4 +42,4 @@ command:
exit-status: 0
stdout:
- 'elasticsearch: http://elasticsearch-master:9200'
- - 'version: 7.3.2'
+ - 'version: 7.4.0'
diff --git a/metricbeat/examples/default/test/goss.yaml b/metricbeat/examples/default/test/goss.yaml
index edb4e13..c1614ab 100644
--- a/metricbeat/examples/default/test/goss.yaml
+++ b/metricbeat/examples/default/test/goss.yaml
@@ -29,12 +29,12 @@ http:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
'http://elasticsearch-master:9200/_search?q=metricset.name:container%20AND%20kubernetes.container.name:metricbeat':
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
file:
/usr/share/metricbeat/metricbeat.yml:
@@ -49,4 +49,4 @@ command:
exit-status: 0
stdout:
- 'elasticsearch: http://elasticsearch-master:9200'
- - 'version: 7.3.2'
+ - 'version: 7.4.0'
diff --git a/metricbeat/examples/oss/test/goss-metrics.yaml b/metricbeat/examples/oss/test/goss-metrics.yaml
index 947a71d..ea98e76 100644
--- a/metricbeat/examples/oss/test/goss-metrics.yaml
+++ b/metricbeat/examples/oss/test/goss-metrics.yaml
@@ -21,12 +21,12 @@ http:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
http://oss-master:9200/_search?q=metricset.name:state_deployment:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
file:
/usr/share/metricbeat/metricbeat.yml:
@@ -40,4 +40,4 @@ command:
exit-status: 0
stdout:
- 'elasticsearch: http://oss-master:9200'
- - 'version: 7.3.2'
+ - 'version: 7.4.0'
diff --git a/metricbeat/examples/oss/test/goss.yaml b/metricbeat/examples/oss/test/goss.yaml
index d39d1b2..3b5c523 100644
--- a/metricbeat/examples/oss/test/goss.yaml
+++ b/metricbeat/examples/oss/test/goss.yaml
@@ -29,12 +29,12 @@ http:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
http://oss-master:9200/_search?q=metricset.name:container:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
file:
/usr/share/metricbeat/metricbeat.yml:
@@ -48,4 +48,4 @@ command:
exit-status: 0
stdout:
- 'elasticsearch: http://oss-master:9200'
- - 'version: 7.3.2'
+ - 'version: 7.4.0'
diff --git a/metricbeat/examples/security/test/goss-metrics.yaml b/metricbeat/examples/security/test/goss-metrics.yaml
index 80d57a8..ecb788f 100644
--- a/metricbeat/examples/security/test/goss-metrics.yaml
+++ b/metricbeat/examples/security/test/goss-metrics.yaml
@@ -21,7 +21,7 @@ http:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
allow-insecure: true
username: '{{ .Env.ELASTICSEARCH_USERNAME }}'
password: '{{ .Env.ELASTICSEARCH_PASSWORD }}'
@@ -29,7 +29,7 @@ http:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
allow-insecure: true
username: '{{ .Env.ELASTICSEARCH_USERNAME }}'
password: '{{ .Env.ELASTICSEARCH_PASSWORD }}'
@@ -46,4 +46,4 @@ command:
exit-status: 0
stdout:
- 'elasticsearch: https://security-master:9200'
- - 'version: 7.3.2'
+ - 'version: 7.4.0'
diff --git a/metricbeat/examples/security/test/goss.yaml b/metricbeat/examples/security/test/goss.yaml
index d25b9de..0e2f04c 100644
--- a/metricbeat/examples/security/test/goss.yaml
+++ b/metricbeat/examples/security/test/goss.yaml
@@ -29,7 +29,7 @@ http:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
allow-insecure: true
username: '{{ .Env.ELASTICSEARCH_USERNAME }}'
password: '{{ .Env.ELASTICSEARCH_PASSWORD }}'
@@ -37,7 +37,7 @@ http:
status: 200
timeout: 2000
body:
- - 'metricbeat-7.3.2'
+ - 'metricbeat-7.4.0'
allow-insecure: true
username: '{{ .Env.ELASTICSEARCH_USERNAME }}'
password: '{{ .Env.ELASTICSEARCH_PASSWORD }}'
@@ -54,4 +54,4 @@ command:
exit-status: 0
stdout:
- 'elasticsearch: https://security-master:9200'
- - 'version: 7.3.2'
+ - 'version: 7.4.0'
diff --git a/metricbeat/values.yaml b/metricbeat/values.yaml
index 5c85249..3f9f0b1 100755
--- a/metricbeat/values.yaml
+++ b/metricbeat/values.yaml
@@ -86,7 +86,7 @@ extraVolumes: ""
hostPathRoot: /var/lib
image: "docker.elastic.co/beats/metricbeat"
-imageTag: "7.3.2"
+imageTag: "7.4.0"
imagePullPolicy: "IfNotPresent"
imagePullSecrets: []
--
1.8.3.1

View File

@ -0,0 +1,40 @@
From 066b7c9996d9bdee56857eca8a1af72bbbaaafff Mon Sep 17 00:00:00 2001
From: Kevin Smith <kevin.smith@windriver.com>
Date: Thu, 24 Oct 2019 11:06:30 -0400
Subject: [PATCH 1/1] set initial masters to master-0
---
elasticsearch/templates/statefulset.yaml | 2 +-
elasticsearch/values.yaml | 3 +++
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/elasticsearch/templates/statefulset.yaml b/elasticsearch/templates/statefulset.yaml
index 36c7af6..e17d39e 100644
--- a/elasticsearch/templates/statefulset.yaml
+++ b/elasticsearch/templates/statefulset.yaml
@@ -233,7 +233,7 @@ spec:
{{- if eq .Values.roles.master "true" }}
{{- if ge (int (include "esMajorVersion" .)) 7 }}
- name: cluster.initial_master_nodes
- value: "{{ template "endpoints" . }}"
+ value: "{{ .Values.initialMasterNodes }}"
{{- else }}
- name: discovery.zen.minimum_master_nodes
value: "{{ .Values.minimumMasterNodes }}"
diff --git a/elasticsearch/values.yaml b/elasticsearch/values.yaml
index 6175540..0d983eb 100755
--- a/elasticsearch/values.yaml
+++ b/elasticsearch/values.yaml
@@ -6,6 +6,9 @@ nodeGroup: "master"
# This should be set to clusterName + "-" + nodeGroup for your master group
masterService: ""
+# On initial cluster formation, the initial set of masters.
+initialMasterNodes: "mon-elasticsearch-master-0"
+
# Elasticsearch roles that will be applied to this nodeGroup
# These will be set as environment variables. E.g. node.master=true
roles:
--
1.8.3.1

View File

@ -0,0 +1,4 @@
---
apiVersion: v1
entries: {}
generated: 2019-01-07T12:33:46.098166523-06:00

View File

@ -0,0 +1,12 @@
---
apiVersion: v1
generated: 2019-01-02T15:19:36.215111369-06:00
repositories:
- caFile: ""
cache: /builddir/.helm/repository/cache/local-index.yaml
certFile: ""
keyFile: ""
name: local
password: ""
url: http://127.0.0.1:8879/charts
username: ""

View File

@ -13,30 +13,32 @@ DEPENDS += " \
PROTOCOL = "https"
BRANCH = "r/stx.3.0"
SRCREV_helm-charts-elastic = "2bd7616ceddbdf2eee88965e2028ee37d304c79c"
SRCREV_monitor-armada-app = "e5ee6b3a07b74479b93fe90eff0662cf81890f73"
# Patches pulled from:
# SRCREV_monitor-armada-app = "e5ee6b3a07b74479b93fe90eff0662cf81890f73"
# git://opendev.org/starlingx/monitor-armada-app.git
SRC_URI = " \
git://github.com/elastic/helm-charts;protocol=${PROTOCOL};name=helm-charts-elastic \
git://opendev.org/starlingx/monitor-armada-app.git;protocol=${PROTOCOL};branch=${BRANCH};name=monitor-armada-app;destsuffix=monitor-armada-app \
"
file://0001-add-makefile.patch \
file://0002-Add-compatibility-for-k8s-1.16.patch \
file://0003-use-oss-image.patch \
file://0004-Update-to-Elastic-7.4.0-Release.patch \
file://0005-set-initial-masters-to-master-0.patch \
file://index.yaml \
file://repositories.yaml \
"
PATCHTOOL = "git"
PATCH_COMMIT_FUNCTIONS = "1"
S = "${WORKDIR}/git"
inherit allarch
patch_folder = "${WORKDIR}/monitor-armada-app/monitor-helm-elastic/files"
helm_folder = "${nonarch_libdir}/helm"
helmchart_version = "0.1.0"
do_patch () {
cd ${S}
git am ${patch_folder}/0001-add-makefile.patch
git am ${patch_folder}/0002-Add-compatibility-for-k8s-1.16.patch
git am ${patch_folder}/0003-use-oss-image.patch
git am ${patch_folder}/0004-Update-to-Elastic-7.4.0-Release.patch
git am ${patch_folder}/0005-set-initial-masters-to-master-0.patch
}
do_configure[noexec] = "1"
do_compile () {
@ -57,11 +59,11 @@ do_compile () {
mkdir ${helm_home}/cache/archive
# Stage a repository file that only has a local repo
install -m 0644 ${patch_folder}/repositories.yaml \
install -m 0644 ${WORKDIR}/repositories.yaml \
${helm_home}/repository/repositories.yaml
# Stage a local repo index that can be updated by the build
install -m 0644 ${patch_folder}/index.yaml ${helm_home}/repository/local/index.yaml
install -m 0644 ${WORKDIR}/index.yaml ${helm_home}/repository/local/index.yaml
# Host a server for the charts
helm serve --repo-path . &
@ -70,7 +72,7 @@ do_compile () {
helm repo add local http://localhost:8879/charts
# Create the tgz files
rm elasticsearch/Makefile
rm -f elasticsearch/Makefile
make elasticsearch
# terminate helm server (the last backgrounded task)