
ceph-disk is used by stx puppet manifest but it's replaced by ceph-volume in ceph 14.1+, and there might be other incompatible issues, so add version 13.2.2 to align with stx 3.0, the version 14.1 is kept so it may be used by future stx release. This includes the following changes: - Add recipe and patches for version 13.2.2 - Set preferred version to 13.2.2 - Rename ceph_%.bbappend to ceph_14.1.0.bbappend - Update the conf file and scripts from stx 2.0 to stx 3.0 - Remove the useless files in stx-integ fix #483 fix #497 Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Babak Sarashki <Babak.SarAshki@windriver.com>
41 lines
1.6 KiB
Diff
41 lines
1.6 KiB
Diff
From a53605694d5301b7bb543464b17f74bbbd35d372 Mon Sep 17 00:00:00 2001
|
|
From: Dengke Du <dengke.du@windriver.com>
|
|
Date: Tue, 28 Aug 2018 10:04:40 +0800
|
|
Subject: [PATCH] Correct the path to find version.h in rocksdb
|
|
|
|
Signed-off-by: Dengke Du <dengke.du@windriver.com>
|
|
---
|
|
cmake/modules/Findrocksdb.cmake | 10 +++++-----
|
|
1 file changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/cmake/modules/Findrocksdb.cmake b/cmake/modules/Findrocksdb.cmake
|
|
index f8369f7..36b67ea 100644
|
|
--- a/cmake/modules/Findrocksdb.cmake
|
|
+++ b/cmake/modules/Findrocksdb.cmake
|
|
@@ -9,17 +9,17 @@
|
|
# ROCKSDB_VERSION_MINOR
|
|
# ROCKSDB_VERSION_PATCH
|
|
|
|
-find_path(ROCKSDB_INCLUDE_DIR rocksdb/db.h)
|
|
+find_path(ROCKSDB_INCLUDE_DIR rocksdb/db.h ${CMAKE_SYSROOT})
|
|
|
|
-find_library(ROCKSDB_LIBRARIES rocksdb)
|
|
+find_library(ROCKSDB_LIBRARIES rocksdb ${CMAKE_SYSROOT})
|
|
|
|
if(ROCKSDB_INCLUDE_DIR AND EXISTS "${ROCKSDB_INCLUDE_DIR}/rocksdb/version.h")
|
|
foreach(ver "MAJOR" "MINOR" "PATCH")
|
|
- file(STRINGS "${ROCKSDB_INCLUDE_DIR}/version.h" ROCKSDB_VER_${ver}_LINE
|
|
+ file(STRINGS "${ROCKSDB_INCLUDE_DIR}/rocksdb/version.h" ROCKSDB_VER_${ver}_LINE
|
|
REGEX "^#define[ \t]+ROCKSDB_${ver}[ \t]+[0-9]+$")
|
|
string(REGEX REPLACE "^#define[ \t]+ROCKSDB_${ver}[ \t]+([0-9]+)$"
|
|
- "\\1" ROCKSDB_VERSION_${ver} "${ROCKDB_VER_${ver}_LINE}")
|
|
- unset(${ROCKDB_VER_${ver}_LINE})
|
|
+ "\\1" ROCKSDB_VERSION_${ver} "${ROCKSDB_VER_${ver}_LINE}")
|
|
+ unset(ROCKSDB_VER_${ver}_LINE)
|
|
endforeach()
|
|
set(ROCKSDB_VERSION_STRING
|
|
"${ROCKSDB_VERSION_MAJOR}.${ROCKSDB_VERSION_MINOR}.${ROCKSDB_VERSION_PATCH}")
|
|
--
|
|
2.7.4
|
|
|