Browse Source

Add python3.9 support

Add python3.9 support, tested locally by running tox.

Story: 2071901
Task: 43189

Signed-off-by: Charles Short <charles.short@windriver.com>
Change-Id: I18071e9fd8d57636ec3637465ef90a7380fb5371
changes/90/807190/7
Charles Short 5 months ago
parent
commit
79fdbd4dde
  1. 19
      .zuul.yaml
  2. 10
      bindep.txt
  3. 5
      python-k8sapp-openstack/k8sapp_openstack/k8sapp_openstack/tests/test_nova_api_proxy.py
  4. 4
      python-k8sapp-openstack/k8sapp_openstack/test-requirements.txt
  5. 17
      python-k8sapp-openstack/k8sapp_openstack/tox.ini

19
.zuul.yaml

@ -3,13 +3,32 @@
check:
jobs:
- openstack-tox-linters
- k8sapp-openstack-tox-py39
gate:
jobs:
- openstack-tox-linters
- k8sapp-openstack-tox-py39
post:
jobs:
- stx-openstack-armada-app-upload-git-mirror
- job:
name: k8sapp-openstack-tox-py39
parent: tox-py39
description: |
Run py39 test for k8app-openstack
nodeset: debian-bullseye
required-projects:
- starlingx/config
- starlingx/fault
- starlingx/update
- starlingx/utilities
files:
- python-k8sapp-openstack/k8sapp_openstack/*
vars:
tox_envlist: py39
python_version: 3.9
tox_extra_args: -c python-k8sapp-openstack/k8sapp_openstack/tox.ini
- job:
name: stx-openstack-armada-app-upload-git-mirror
parent: upload-git-mirror

10
bindep.txt

@ -0,0 +1,10 @@
# This is a cross-platform list tracking distribution packages needed for install and tests;
# see https://docs.openstack.org/infra/bindep/ for additional information.
libffi-dev [platform:dpkg]
libldap2-dev [platform:dpkg]
libxml2-dev [platform:dpkg]
libxslt1-dev [platform:dpkg]
libsasl2-dev [platform:dpkg]
libffi-devel [platform:rpm]
python3-all-dev [platform:dpkg]

5
python-k8sapp-openstack/k8sapp_openstack/k8sapp_openstack/tests/test_nova_api_proxy.py

@ -22,7 +22,7 @@ class NovaApiProxyTestCase(test_plugins.K8SAppOpenstackAppMixin,
class NovaApiProxyIPv4ControllerHostTestCase(NovaApiProxyTestCase,
dbbase.ControllerHostTestCase):
dbbase.ProvisionedControllerHostTestCase):
def test_replicas(self):
overrides = self.operator.get_helm_chart_overrides(
@ -36,7 +36,8 @@ class NovaApiProxyIPv4ControllerHostTestCase(NovaApiProxyTestCase,
class NovaApiProxyIPv4AIODuplexSystemTestCase(NovaApiProxyTestCase,
dbbase.AIODuplexSystemTestCase):
dbbase.ProvisionedAIODuplexSystemTestCase):
def test_replicas(self):
overrides = self.operator.get_helm_chart_overrides(

4
python-k8sapp-openstack/k8sapp_openstack/test-requirements.txt

@ -10,11 +10,9 @@ fixtures>=3.0.0 # Apache-2.0/BSD
mock>=2.0.0 # BSD
passlib>=1.7.0
psycopg2-binary
python-barbicanclient<3.1.0,>=3.0.1
python-barbicanclient>=4.5.2 # Apache-2.0
python-subunit>=0.0.18
requests-mock>=0.6.0 # Apache-2.0
sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
oslosphinx<2.6.0,>=2.5.0 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
stestr>=1.0.0 # Apache-2.0
testrepository>=0.0.18

17
python-k8sapp-openstack/k8sapp_openstack/tox.ini

@ -1,5 +1,5 @@
[tox]
envlist = flake8,py27,py36,pylint
envlist = flake8,py27,py36,py39,pylint
minversion = 1.6
# skipsdist = True
#,pip-missing-reqs
@ -14,8 +14,8 @@ distshare={toxworkdir}/.tox/distshare
# enabling usedevelop results in py27 develop-inst:
# Exception: Versioning for this project requires either an sdist tarball,
# or access to an upstream git repository.
# Note. site-packages is true and rpm-python must be yum installed on your dev machine.
sitepackages = True
# Note. site-packages is false and rpm-python must be yum installed on your dev machine.
sitepackages = False
# tox is silly... these need to be separated by a newline....
whitelist_externals = bash
@ -119,6 +119,17 @@ commands =
stestr run {posargs}
stestr slowest
[testenv:py39]
basepython = python3.9
install_command = pip install --use-deprecated legacy-resolver\
-v -v -v \
-c{env:UPPER_CONSTRAINTS_FILE:https://opendev.org/starlingx/root/raw/branch/master/build-tools/requirements/debian/upper-constraints.txt} \
{opts} {packages}
commands =
{[testenv]commands}
stestr run {posargs}
stestr slowest
[testenv:pep8]
# testenv:flake8 clone
basepython = {[testenv:flake8]basepython}

Loading…
Cancel
Save