
"dl_path" replaces the ${HORIZON_TAR_BALL} in dl_hook "src_files" replaces the ${PKG_BUILD_DIR}/files in dl_hook derepack copies the "src_files" into build directory, not the sub-directory "files", so update the installing procedure of 0001-install-extra-files.patch. Test Plan: Pass: successfully build test Story: 2009101 Task: 43740 Signed-off-by: Yue Tao <yue.tao@windriver.com> Change-Id: I1c73cdd9de2c80973ac6bc8be1eb9a7dd78a5ffa
60 lines
2.8 KiB
Diff
60 lines
2.8 KiB
Diff
From 2410e5ae2150100c7a4c01886498935c57076822 Mon Sep 17 00:00:00 2001
|
|
From: Fabricio Henrique Ramos <fabriciohenrique.ramos@windriver.com>
|
|
Date: Fri, 22 Oct 2021 14:11:23 -0300
|
|
Subject: [PATCH] install extra files
|
|
|
|
Signed-off-by: Yue Tao <Yue.Tao@windriver.com>
|
|
---
|
|
debian/openstack-dashboard.install | 8 ++++++++
|
|
debian/python3-django-horizon.install | 1 +
|
|
debian/rules | 10 ++++++++++
|
|
3 files changed, 19 insertions(+)
|
|
|
|
diff --git a/debian/openstack-dashboard.install b/debian/openstack-dashboard.install
|
|
index 2be73b9..12f33b9 100644
|
|
--- a/debian/openstack-dashboard.install
|
|
+++ b/debian/openstack-dashboard.install
|
|
@@ -1,3 +1,11 @@
|
|
debian/local_settings.d/* usr/share/openstack-dashboard-debian-settings.d
|
|
etc/openstack-dashboard
|
|
+etc/httpd/conf.d/openstack-dashboard.conf
|
|
+etc/logrotate.d/openstack-dashboard
|
|
+etc/rc.d/init.d/horizon
|
|
usr/share/openstack-dashboard
|
|
+usr/share/openstack-dashboard/guni_config.py
|
|
+usr/bin/horizon-clearsessions
|
|
+usr/bin/horizon-patching-restart
|
|
+usr/bin/horizon-assets-compress
|
|
+usr/lib/systemd/system/httpd.service.d/openstack-dashboard.conf
|
|
diff --git a/debian/python3-django-horizon.install b/debian/python3-django-horizon.install
|
|
index 47e0ed4..a113003 100644
|
|
--- a/debian/python3-django-horizon.install
|
|
+++ b/debian/python3-django-horizon.install
|
|
@@ -1 +1,2 @@
|
|
/usr/lib/python*
|
|
+usr/share/doc/python3-django-horizon/openstack-dashboard-httpd-logging.conf
|
|
diff --git a/debian/rules b/debian/rules
|
|
index 53181a6..4ab08e7 100755
|
|
--- a/debian/rules
|
|
+++ b/debian/rules
|
|
@@ -95,6 +95,16 @@ override_dh_auto_install:
|
|
## Delete not needed files
|
|
rm -f $(CURDIR)/debian/tmp/usr/lib/python3/dist-packages/openstack_dashboard/local/_build*.lock
|
|
|
|
+ install -D -p -m 644 $(CURDIR)/openstack-dashboard-httpd-2.4.conf $(CURDIR)/debian/tmp/etc/httpd/conf.d/openstack-dashboard.conf
|
|
+ install -D -p -m 644 $(CURDIR)/python-django-horizon-systemd.conf $(CURDIR)/debian/tmp/usr/lib/systemd/system/httpd.service.d/openstack-dashboard.conf
|
|
+ install -D -p $(CURDIR)/openstack-dashboard-httpd-logging.conf $(CURDIR)/debian/tmp/usr/share/doc/python3-django-horizon/openstack-dashboard-httpd-logging.conf
|
|
+ install -D -p $(CURDIR)/python-django-horizon-logrotate.conf $(CURDIR)/debian/tmp/etc/logrotate.d/openstack-dashboard
|
|
+ install -D -p -m 755 $(CURDIR)/horizon.init $(CURDIR)/debian/tmp/etc/rc.d/init.d/horizon
|
|
+ install -D -p -m 755 $(CURDIR)/horizon-clearsessions $(CURDIR)/debian/tmp/usr/bin/horizon-clearsessions
|
|
+ install -D -p -m 755 $(CURDIR)/horizon-patching-restart $(CURDIR)/debian/tmp/usr/bin/horizon-patching-restart
|
|
+ install -D -p $(CURDIR)/guni_config.py $(CURDIR)/debian/tmp/usr/share/openstack-dashboard/guni_config.py
|
|
+ install -D -p -m 755 $(CURDIR)/horizon-assets-compress $(CURDIR)/debian/tmp/usr/bin/horizon-assets-compress
|
|
+
|
|
dh_install
|
|
dh_missing --fail-missing
|
|
find $(CURDIR)/debian -iname .eslintrc -delete
|
|
--
|
|
2.25.1
|
|
|