
Add Debian packaging infrastruture to build python-pankoclient. Story: 2009101 Task: 43795 Signed-off-by: Charles Short <charles.short@windriver.com> Change-Id: I791bb0b728d2641b195320e61ecc36f510d2deea
57 lines
1.7 KiB
Diff
57 lines
1.7 KiB
Diff
From baa05e47ddc62bed291680d9ee37d37bb8bc594c Mon Sep 17 00:00:00 2001
|
|
From: Charles Short <charles.short@windriver.com>
|
|
Date: Wed, 27 Oct 2021 14:29:42 +0000
|
|
Subject: [PATCH] Add wheel package
|
|
|
|
Add python3-pankclient-wheel.
|
|
|
|
Signed-off-by: Charles Short <charles.short@windriver.com>
|
|
---
|
|
debian/control | 19 +++++++++++++++++++
|
|
debian/rules | 2 +-
|
|
2 files changed, 20 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/debian/control b/debian/control
|
|
index 007fc55..24470c7 100644
|
|
--- a/debian/control
|
|
+++ b/debian/control
|
|
@@ -83,3 +83,22 @@ Description: Client library for OpenStack panko server - Python 3.x
|
|
command-line tool (openstack event).
|
|
.
|
|
This package provides the Python 3.x module.
|
|
+
|
|
+Package: python3-pankoclient-wheel
|
|
+Architecture: all
|
|
+Depends:
|
|
+ python3-wheel,
|
|
+ ${misc:Depends},
|
|
+ ${python3:Depends},
|
|
+Description: Client library for OpenStack panko server - Python 3.x
|
|
+ The Panko project is an event storage service that provides the ability to
|
|
+ store and querying event data generated by Ceilometer with potentially other
|
|
+ sources.
|
|
+ .
|
|
+ Panko is a component of the Telemetry project.
|
|
+ .
|
|
+ This is a client library for Panko built on the Panko API. It provides a
|
|
+ Python API (the pankoclient module) and a OSC (the openstackclient CLI)
|
|
+ command-line tool (openstack event).
|
|
+ .
|
|
+ This package contains the Python wheel.
|
|
diff --git a/debian/rules b/debian/rules
|
|
index 612ce0e..d770e0f 100755
|
|
--- a/debian/rules
|
|
+++ b/debian/rules
|
|
@@ -12,7 +12,7 @@ override_dh_auto_build:
|
|
echo "Do nothing..."
|
|
|
|
override_dh_auto_install:
|
|
- pkgos-dh_auto_install --no-py2
|
|
+ pkgos-dh_auto_install --no-py2 --wheel
|
|
|
|
override_dh_auto_test:
|
|
ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
|
|
--
|
|
2.30.2
|
|
|