Browse Source

Force the Puppet Package provider to apt_fuel for collectd package

This allows to install unauthenitcated packages.

Change-Id: I23014138f5ce29a17dec0819c1d422676190e522
Closes-bug: #1663498
tags/1.0.0^0
Swann Croiset 2 years ago
parent
commit
3cb3a9efdd

+ 2
- 0
deployment_scripts/puppet/modules/lma_collector/manifests/collectd/base.pp View File

@@ -19,6 +19,7 @@ class lma_collector::collectd::base (
19 19
   $read_threads = $lma_collector::params::collectd_read_threads,
20 20
   $hostname = undef,
21 21
   $purge = false,
22
+  $package_provider = 'apt_fuel',
22 23
 ) inherits lma_collector::params {
23 24
 
24 25
   include lma_collector::service::metric
@@ -49,6 +50,7 @@ class lma_collector::collectd::base (
49 50
   class { '::collectd':
50 51
     purge                  => $purge,
51 52
     recurse                => true,
53
+    package_provider       => $package_provider,
52 54
     purge_config           => true,
53 55
     fqdnlookup             => false,
54 56
     interval               => $lma_collector::params::collectd_interval,

Loading…
Cancel
Save