Browse Source

Fix Puppet tests again

Change-Id: I749ed33b57efc2455ca56959267329048cc43973
changes/38/451238/1
Simon Pasquier 2 years ago
parent
commit
a90c6cc9b7

+ 2
- 0
deployment_scripts/puppet/manifests/Gemfile View File

@@ -18,4 +18,6 @@ group :development, :test do
18 18
   gem "puppet", ENV['PUPPET_VERSION'] || '~> 3.4.0'
19 19
   # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0
20 20
   gem 'puppetlabs_spec_helper', '~> 1.1.1'
21
+  # puppet-lint >= 2.2.0 don't support Puppet 3.x anymore
22
+  gem 'puppet-lint', '~> 2.1.0'
21 23
 end

+ 2
- 0
deployment_scripts/puppet/modules/fuel_lma_collector/Gemfile View File

@@ -21,5 +21,7 @@ group :development, :test do
21 21
   gem 'rspec-puppet-facts'
22 22
   # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0
23 23
   gem 'puppetlabs_spec_helper', '~> 1.1.1'
24
+  # puppet-lint >= 2.2.0 don't support Puppet 3.x anymore
25
+  gem 'puppet-lint', '~> 2.1.0'
24 26
   gem 'metadata-json-lint'
25 27
 end

+ 2
- 0
deployment_scripts/puppet/modules/heka/Gemfile View File

@@ -21,5 +21,7 @@ group :development, :test do
21 21
   gem 'rspec-puppet-facts'
22 22
   # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0
23 23
   gem 'puppetlabs_spec_helper', '~> 1.1.1'
24
+  # puppet-lint >= 2.2.0 don't support Puppet 3.x anymore
25
+  gem 'puppet-lint', '~> 2.1.0'
24 26
   gem 'metadata-json-lint'
25 27
 end

+ 2
- 0
deployment_scripts/puppet/modules/lma_collector/Gemfile View File

@@ -21,5 +21,7 @@ group :development, :test do
21 21
   gem 'rspec-puppet-facts'
22 22
   # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0
23 23
   gem 'puppetlabs_spec_helper', '~> 1.1.1'
24
+  # puppet-lint >= 2.2.0 don't support Puppet 3.x anymore
25
+  gem 'puppet-lint', '~> 2.1.0'
24 26
   gem 'metadata-json-lint'
25 27
 end

Loading…
Cancel
Save