Browse Source

Fix issue with task install_ocf_script on MOS8

This patch fixes an issue with the compatibility between the task
'install_ocf_script' and MOS8. On MOS 8 the following error is
raised:

"Tasks 'primary-standalone-database, primary-standalone-rabbitmq,
standalone-database, standalone-rabbitmq' can't be in
requires|required_for|groups|tasks for [install-ocf-script] because they
don't exist in the graph"

Change-Id: I97e5fd6321c9f7a5878e1b8db9f37cec15745676
Closes-Bug: #1627968
(cherry picked from commit 76987240a9)
tags/0.10.2rc2^0
Guillaume Thouvenin 2 years ago
parent
commit
c3106130a5
1 changed files with 1 additions and 1 deletions
  1. 1
    1
      deployment_tasks.yaml

+ 1
- 1
deployment_tasks.yaml View File

@@ -5,7 +5,7 @@
5 5
 - id: install-ocf-script
6 6
   type: puppet
7 7
   version: 2.0.0
8
-  groups: [primary-controller, controller, primary-standalone-database, standalone-database, primary-standalone-rabbitmq, standalone-rabbitmq]
8
+  groups: ["/(primary-)?(controller|standalone-database|standalone-rabbitmq)/"]
9 9
   requires: [fuel_pkgs]
10 10
   # Required for the cluster tasks when the environment is scaled up
11 11
   required_for: [primary-cluster, cluster]

Loading…
Cancel
Save