Browse Source

Added "Limitations" section, change version to 3.2.1 in docs

Change-Id: I3c0eab8311bee1f58ee5f97550fa34797a35880c
tags/fuel8_cx5
Hamdy Khader 2 years ago
parent
commit
244325118c

+ 2
- 2
doc/source/conf.py View File

@@ -57,7 +57,7 @@ copyright = u'2016, mellanox'
57 57
 # The short X.Y version.
58 58
 version = '3.2'
59 59
 # The full version, including alpha/beta/rc tags.
60
-release = '3.2-3.2.0-1'
60
+release = '3.2-3.2.1-1'
61 61
 
62 62
 # The language for content autogenerated by Sphinx. Refer to documentation
63 63
 # for a list of supported languages.
@@ -238,7 +238,7 @@ latex_elements = { 'classoptions': ',openany,oneside', 'babel' : '\\usepackage[e
238 238
 # One entry per manual page. List of tuples
239 239
 # (source start file, name, description, authors, manual section).
240 240
 man_pages = [
241
-    ('index', 'fuel-plugin-mellanox', u'Guide to the Mellanox ConnectX-4 plugin ver. 3.2-3.2.0-1 for Fuel 8',
241
+    ('index', 'fuel-plugin-mellanox', u'Guide to the Mellanox ConnectX-4 plugin ver. 3.2-3.2.1-1 for Fuel 8',
242 242
      [u'Mellanox'], 1)
243 243
 ]
244 244
 

+ 1
- 1
doc/source/index.rst View File

@@ -4,7 +4,7 @@
4 4
    contain the root `toctree` directive.
5 5
 
6 6
 =====================================================================
7
-Guide to the Mellanox ConnectX-4 Plugin ver. 3.2-3.2.0-1 for Fuel
7
+Guide to the Mellanox ConnectX-4 Plugin ver. 3.2-3.2.1-1 for Fuel
8 8
 =====================================================================
9 9
 
10 10
 User documentation

+ 3
- 4
doc/source/installation.rst View File

@@ -11,19 +11,19 @@ To install Mellanox plugin, follow these steps:
11 11
 #. Download the plugin rpm file for MOS 8.0 from `Fuel Plugin Catalog <https://www.mirantis.com/products/openstack-drivers-and-plugins/fuel-plugins>`_.
12 12
 #. Copy the plugin on already installed Fuel Master. scp can be used for that.::
13 13
 
14
-   # scp mellanox-plugin-3.2-3.2.0-1.noarch.rpm root@<Fuel_Master_ip>:/tmp
14
+   # scp mellanox-plugin-3.2-3.2.1-1.noarch.rpm root@<Fuel_Master_ip>:/tmp
15 15
 
16 16
 #. Install the plugin::
17 17
 
18 18
    # cd /tmp
19
-   # fuel plugins --install mellanox-plugin-3.2-3.2.0-1.noarch.rpm
19
+   # fuel plugins --install mellanox-plugin-3.2-3.2.1-1.noarch.rpm
20 20
 
21 21
 #. Verify the plugin was installed successfully by having it listed using ``fuel plugins`` command::
22 22
 
23 23
    # fuel plugins
24 24
    #  id | name              | version | package_version
25 25
    #  ---|-------------------|---------|----------------
26
-   #  1  | mellanox-plugin   | 3.2.0   | 3.0.0
26
+   #  1  | mellanox-plugin   | 3.2.1   | 3.0.0
27 27
 
28 28
 #. Define bootstrap discovery parameters to be burnt on Mellanox Adapters cards:
29 29
 
@@ -170,4 +170,3 @@ To install Mellanox plugin, follow these steps:
170 170
 #. When using SR-IOV you can set the number of virtual NICs (virtual functions) to up to 31
171 171
    if your hardware and system capabilities like memory and BIOS support it).
172 172
    In any case of SR-IOV hardware limitation, the installation will try to fallback a VF number to the default of 16 VFs.
173
-

+ 6
- 0
doc/source/overview.rst View File

@@ -47,3 +47,9 @@ Requirements
47 47
  (e.g. SN2700 (ETH), SB7700 (IB)). The switch ports should be configured specifically to use 100 Gb speed. No
48 48
  additional configuration is required on the adapter side.
49 49
 
50
+Limitations
51
+-----------
52
+| 1. when using iSER and bonding, the storage interface will be a virtual function under the first
53
+ port, and will not support failover.
54
+| 2. when using SR-IOV and bonding, the virtual functions will be created and allocated from the
55
+ first interface, and failover is not supported.

+ 1
- 1
doc/source/supported_images.rst View File

@@ -15,4 +15,4 @@ Supported images
15 15
 |   3   | Cirros Mellanox    | 3.11.0-26-generic               |
16 16
 +-------+--------------------+---------------------------------+
17 17
 
18
-This Fuel Mellanox plugin ver. 3.2-3.2.0-1 is using MLNX_OFED_LINUX version 3.3-1.5.0.
18
+This Fuel Mellanox plugin ver. 3.2-3.2.1-1 is using MLNX_OFED_LINUX version 3.3-1.5.0.

Loading…
Cancel
Save