Browse Source

Add proper support for MOS 7.0 and MOS 8.0

Change-Id: Ic43d7082ba63a99ac1bffaeacf9150af46e694e4
Olivier Bourdon 3 years ago
parent
commit
d95c2bbbc0

+ 2
- 0
deployment_tasks.yaml View File

@@ -0,0 +1,2 @@
1
+---
2
+[]

+ 0
- 2
doc/plugin-guide/source/guide.rst View File

@@ -18,8 +18,6 @@ Known problems
18 18
 
19 19
 - `#1529643 <https://bugs.launchpad.net/fuel-plugins/+bug/1529643>`_:
20 20
   Zabbix snmptrapd: Service "snmptt" was restarted after executing of task "upload\_core\_repos"
21
-- `#1538617 <https://bugs.launchpad.net/fuel-plugins/+bug/1538617>`_:
22
-  Cross-plugin display restrictions for some plugins prevent Settings tab from opening.
23 21
 - See Zabbix Plugin for Fuel Documentation for additional problems
24 22
 
25 23
 Environment configuration

+ 1
- 1
doc/plugin-guide/source/installation.rst View File

@@ -34,7 +34,7 @@ To install SNMP trap daemon for Zabbix plugin, follow these steps:
34 34
     id | name                      | version  | package_version
35 35
     ---|---------------------------|----------|----------------
36 36
     1  | zabbix_monitoring         | 2.5.0    | 3.0.0
37
-    2  | zabbix_snmptrapd          | 1.0.1    | 2.0.0
37
+    2  | zabbix_snmptrapd          | 1.0.1    | 3.0.0
38 38
 
39 39
 SNMP trap daemon for Zabbix plugin removal
40 40
 ==========================================

+ 2
- 2
environment_config.yaml View File

@@ -1,8 +1,8 @@
1 1
 attributes:
2 2
   metadata:
3 3
     restrictions:
4
-      - condition: "settings:zabbix_monitoring == null or settings:zabbix_monitoring.metadata.enabled == false"
5
-        action: disable
4
+      - condition: "settings:zabbix_monitoring == null or settings:zabbix_monitoring.metadata.enabled == false or cluster:net_provider != 'neutron'"
5
+        action: "hide"
6 6
         message: "This plugin requires Zabbix plugin"
7 7
         strict: false
8 8
   community:

+ 1
- 1
metadata.yaml View File

@@ -30,4 +30,4 @@ releases:
30 30
     repository_path: repositories/ubuntu
31 31
 
32 32
 # Version of plugin package
33
-package_version: '2.0.0'
33
+package_version: '3.0.0'

Loading…
Cancel
Save