Browse Source

Syncing with mitaka dependencies

Change-Id: I99448977f2078437c083e684769c50ce432a8f68
Sumit Naiksatam 3 years ago
parent
commit
1ec1bec0a6
3 changed files with 26 additions and 17 deletions
  1. 1
    0
      requirements.txt
  2. 9
    2
      setup.py
  3. 16
    15
      test-requirements.txt

+ 1
- 0
requirements.txt View File

@@ -2,4 +2,5 @@
2 2
 # of appearance. Changing the order has an impact on the overall integration
3 3
 # process, which may cause wedges in the gate later.
4 4
 
5
+pbr>=1.6 # Apache-2.0
5 6
 Babel>=1.3

+ 9
- 2
setup.py View File

@@ -1,4 +1,3 @@
1
-#!/usr/bin/env python
2 1
 # Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
3 2
 #
4 3
 # Licensed under the Apache License, Version 2.0 (the "License");
@@ -17,6 +16,14 @@
17 16
 # THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
18 17
 import setuptools
19 18
 
19
+# In python < 2.7.4, a lazy loading of package `pbr` will break
20
+# setuptools if some other modules registered functions in `atexit`.
21
+# solution from: http://bugs.python.org/issue15881#msg170215
22
+try:
23
+    import multiprocessing  # noqa
24
+except ImportError:
25
+    pass
26
+
20 27
 setuptools.setup(
21
-    setup_requires=['pbr'],
28
+    setup_requires=['pbr>=1.8'],
22 29
     pbr=True)

+ 16
- 15
test-requirements.txt View File

@@ -2,23 +2,24 @@
2 2
 # of appearance. Changing the order has an impact on the overall integration
3 3
 # process, which may cause wedges in the gate later.
4 4
 
5
--e git://github.com/openstack/heat.git@stable/liberty#egg=heat
5
+-e git://github.com/openstack/heat.git@master#egg=heat
6 6
 -e git://git.openstack.org/openstack/python-group-based-policy-client.git@master#egg=gbpclient
7 7
 # Hacking already pins down pep8, pyflakes and flake8
8 8
 hacking<0.11,>=0.10.0
9
-coverage>=3.6
10
-mock>=1.2
11
-mox>=0.5.3
12
-mox3>=0.7.0
9
+bandit>=0.17.3 # Apache-2.0
10
+coverage>=3.6 # Apache-2.0
11
+kombu>=3.0.25 # BSD
12
+mock>=1.2 # BSD
13
+mox3>=0.7.0 # Apache-2.0
13 14
 PyMySQL>=0.6.2 # MIT License
14
-oslosphinx>=2.5.0 # Apache-2.0
15
+oslosphinx!=3.4.0,>=2.5.0 # Apache-2.0
15 16
 oslotest>=1.10.0 # Apache-2.0
16
-paramiko>=1.13.0
17
-qpid-python;python_version=='2.7'
18
-psycopg2>=2.5
19
-reno[sphinx]>=0.1.1  # Apache2
20
-sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
21
-testrepository>=0.0.18
22
-testscenarios>=0.4
23
-testtools>=1.4.0
24
-testresources>=0.2.4
17
+paramiko>=1.16.0 # LGPL
18
+qpid-python;python_version=='2.7' # Apache-2.0
19
+psycopg2>=2.5 # LGPL/ZPL
20
+sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2 # BSD
21
+testrepository>=0.0.18 # Apache-2.0/BSD
22
+testscenarios>=0.4 # Apache-2.0/BSD
23
+testtools>=1.4.0 # MIT
24
+testresources>=0.2.4 # Apache-2.0/BSD
25
+reno>=0.1.1 # Apache2

Loading…
Cancel
Save