Browse Source

Newton sync

Change-Id: I3bdd81ad1ddf3bda79016bb6af64d1ae5092bb7f
Sumit Naiksatam 2 years ago
parent
commit
34c73a3629
2 changed files with 13 additions and 9 deletions
  1. 2
    1
      gbpautomation/heat/engine/clients/os/grouppolicy.py
  2. 11
    8
      test-requirements.txt

+ 2
- 1
gbpautomation/heat/engine/clients/os/grouppolicy.py View File

@@ -32,7 +32,8 @@ class GBPClientPlugin(client_plugin.ClientPlugin):
32 32
         args = {
33 33
             'auth_url': con.auth_url,
34 34
             'service_type': 'network',
35
-            'token': self.auth_token,
35
+            'token': con.keystone_session.get_token(),
36
+            'project_id': con.tenant_id,
36 37
             'endpoint_url': endpoint,
37 38
             'endpoint_type': endpoint_type,
38 39
             'ca_cert': self._get_client_option('grouppolicy', 'ca_file'),

+ 11
- 8
test-requirements.txt View File

@@ -2,25 +2,28 @@
2 2
 # of appearance. Changing the order has an impact on the overall integration
3 3
 # process, which may cause wedges in the gate later.
4 4
 
5
--e git://github.com/openstack/heat.git@stable/mitaka#egg=heat
5
+-e git://github.com/openstack/heat.git@stable/newton#egg=heat
6 6
 -e git://git.openstack.org/openstack/python-group-based-policy-client.git@master#egg=gbpclient
7 7
 # Hacking already pins down pep8, pyflakes and flake8
8 8
 hacking<0.11,>=0.10.0
9
-bandit>=0.17.3 # Apache-2.0
9
+bandit>=1.1.0 # Apache-2.0
10 10
 coverage>=3.6 # Apache-2.0
11
-kombu>=3.0.25 # BSD
12
-mock>=1.2 # BSD
11
+fixtures>=3.0.0 # Apache-2.0/BSD
12
+kombu<4.0.0,>=3.0.25 # BSD
13
+mock>=2.0 # BSD
13 14
 mox3>=0.7.0 # Apache-2.0
14
-PyMySQL>=0.6.2 # MIT License
15
+PyMySQL!=0.7.7,>=0.6.2 # MIT License
16
+openstackdocstheme>=1.5.0 # Apache-2.0
17
+os-api-ref>=1.0.0 # Apache-2.0
15 18
 oslosphinx!=3.4.0,>=2.5.0 # Apache-2.0
16 19
 oslotest>=1.10.0 # Apache-2.0
17
-paramiko>=1.16.0 # LGPL
18 20
 qpid-python;python_version=='2.7' # Apache-2.0
19 21
 psycopg2>=2.5 # LGPL/ZPL
22
+python-glanceclient>=2.3.0,!=2.4.0,<2.6.0
20 23
 python-troveclient<2.6.0
21
-sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2 # BSD
24
+sphinx!=1.3b1,<1.3,>=1.2.1 # BSD
22 25
 testrepository>=0.0.18 # Apache-2.0/BSD
23 26
 testscenarios>=0.4 # Apache-2.0/BSD
24 27
 testtools>=1.4.0 # MIT
25 28
 testresources>=0.2.4 # Apache-2.0/BSD
26
-reno>=0.1.1 # Apache2
29
+reno>=1.8.0 # Apache2

Loading…
Cancel
Save