group-based-policy-automation/test-requirements.txt
sonianuj287 4f95f7deb2 Group Based Policy Automation - Antelope Support
Change-Id: Icc3dbc98be05305ac2d6f5bbb927363973c58c31
2024-03-13 18:04:05 +00:00

27 lines
1.0 KiB
Plaintext

# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
-e git+https://opendev.org/openstack/heat.git@stable/2023.1#egg=openstack-heat
-e git+https://opendev.org/x/python-group-based-policy-client.git@stable/2023.1#egg=python-group-based-policy-client
# Hacking already pins down pep8, pyflakes and flake8
hacking>=3.0.1,<3.1.0; # Apache-2.0
# remove this pyflakes from here once you bump the
# hacking to 3.2.0 or above. hacking 3.2.0 takes
# care of pyflakes version compatibilty.
pyflakes>=2.1.1
bandit!=1.6.0,>=1.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
flake8-import-order==0.12 # LGPLv3
kombu!=4.0.2,>=5.0.1 # BSD
PyMySQL>=0.8.0 # MIT License
os-testr>=1.0.0 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
psycopg2>=2.8 # LGPL/ZPL
stestr>=2.0.0 # Apache-2.0
testrepository>=0.0.18 # Apache-2.0/BSD
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
testresources>=2.0.0 # Apache-2.0/BSD